This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 1026514 - libvirt does not work or print out an error message if you setup a strange LOCALE
libvirt does not work or print out an error message if you setup a strange LO...
Status: CLOSED DUPLICATE of bug 1016158
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 15:55 EST by Daniel Walsh
Modified: 2013-11-04 16:05 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 16:05:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2013-11-04 15:55:05 EST
I was playing around with /etc/locale.conf at one point and added the following LANG entry.

more /etc/locale.conf 
LANG=en_EN.utf8

This caused systemd to set the LANG variable before starting a service.
When I started libvirtd it would fail without putting out any message even in debug mode.

I eventually replaced libvirtd with a script that did an strace of libvirtd to figure out what was going on.
Comment 1 Eric Blake 2013-11-04 16:05:21 EST

*** This bug has been marked as a duplicate of bug 1016158 ***

Note You need to log in before you can comment on or make changes to this bug.