Bug 102653 - mkinitrd fails with "insmod:
mkinitrd fails with "insmod:
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mkinitrd (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-19 10:19 EDT by Lucio DiGiovanni
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 11:37:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucio DiGiovanni 2003-08-19 10:19:49 EDT
Description of problem: Every time I do mkinitrd to create a RAM disk image I
get error from tar: ./bin/insmod: Wrote only 2560 of 10240 bytes


Version-Release number of selected component (if applicable): mkinitrd version
2.2.5-15


How reproducible: Every time


Steps to Reproduce:
[root@ia64-l82bi189 root]# ./doboot > mkinitrdErr.txt

+ alias 'rm=rm -i'

+ alias 'cp=cp -i'

+ alias 'mv=mv -i'

+ '[' -f /etc/bashrc ']'

+ . /etc/bashrc

+++ id -gn

+++ id -un

+++ id -u

++ '[' root = root -a 0 -gt 99 ']'

++ umask 022

++ '[' '' ']'

+ cd /usr/src/linux

+ gzip -c vmlinux > /boot/efi/vmlinuz-2.4.18-e.31smp

+ cp vmlinux /boot/efi/vmlinux-2.4.18-e.31smp

+ cp System.map /boot/System.map-2.4.18-e.31smp

+ cd /boot

+ ln -sf efi/vmlinuz-2.4.18-e.31smp vmlinuz-2.4.18-e.31smp

+ rm System.map

+ ln -sf System.map-2.4.18-e.31smp System.map

+ ln -sf efi/initrd-2.4.18-e.31smp.img initrd-2.4.18-e.31smp.img

+ cd efi

+ mkinitrd -f initrd-2.4.18-e.31smp.img 2.4.18-e.31smp

tar: ./bin/insmod: Wrote only 2560 of 10240 bytes

tar: Error exit delayed from previous errors




    
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2003-08-19 10:41:28 EDT
How big is your initrd?  What modules are being included in it?

The simple workaround is to change IMAGESIZE as defined at the top of mkinitrd
(this is done in newer versions because it became a problem with the Red Hat
Enterprise Linux 3 beta, but I never saw or heard of it being a problem with 2.1)
Comment 2 Lucio DiGiovanni 2003-08-19 10:53:20 EDT
My initrd is 1259160 bytes

Modules being added are:

eth0 e1000
eth1 e1000
scsi_hostadapter mptbase
scsi_hostadapter1 mptscsih
scsi_hostadapter2 qla2300
scsi_hostadapter3 mptscsih
scsi_hostadapter4 mptscsih
scsi_hostadapter5 qla2300
scsi_hostadapter6 qla2300
usb-controller usb-uhci


Comment 3 Jeremy Katz 2003-08-19 10:59:55 EDT
Yeah, you're probably hitting the imagesize.  If you bump the number does it work?
Comment 4 Lucio DiGiovanni 2003-08-19 11:11:38 EDT
Sorry Jeremy,
I am a little new to this (I do not want to be called a Linux Newbie :)

I tried looking for mkinitrd.c or .h without any success.

How do I change the imagesize?
Comment 5 Jeremy Katz 2003-08-19 11:19:45 EDT
mkinitrd is just a simple shell script...  look at /sbin/mkinitrd and you should
find IMAGESIZE=4000 pretty quickly.  Change the 4000 to an 8000 and that should
do it.
Comment 6 Lucio DiGiovanni 2003-08-19 11:26:52 EDT
Your work-around works!

Thanks.

Does this qualify as a REAL bug?
Comment 7 Jeremy Katz 2003-08-19 11:37:11 EDT
Yep, it's fixed in newer versions, though.

Note You need to log in before you can comment on or make changes to this bug.