Bug 1026535 - RFE: Add auto_assign_floating_ip as a host group parameter for nova controller.pp and compute.pp
RFE: Add auto_assign_floating_ip as a host group parameter for nova controlle...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
4.0
All Linux
unspecified Severity low
: rc
: 4.0
Assigned To: Jason Guiditta
Ofer Blaut
: FutureFeature, OtherQA
Depends On:
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-11-04 17:29 EST by jliberma@redhat.com
Modified: 2013-12-19 19:33 EST (History)
11 users (show)

See Also:
Fixed In Version: openstack-foreman-installer-0.0.23-1.el6ost
Doc Type: Enhancement
Doc Text:
Automatic IP address assignment for instances is now optional. This feature is managed by the host group parameter 'auto_assign_floating_ip' for Compute controller.pp and compute.pp.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:33:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jliberma@redhat.com 2013-11-04 17:29:15 EST
Description of problem: Foreman nova/compute.pp and controller.pp puppet manifests must be edited to disable auto_assign_floating_ip. As an RFE, please allow this feature to be disabled as a host group parameter.

Version-Release number of selected component (if applicable):
2013.2-4

How reproducible: 
Every time

Steps to Reproduce:
1. Install RHEL 6.5
2. Install OSP4 via Foreman, accept all defaults
3. grep auto_assign from /etc/nova/nova.comp

Actual results:
Floating IP addresses are automatically assigned to instances

Expected results:


Additional info:
Comment 2 Solly Ross 2013-11-06 17:22:21 EST
refiling as a foreman-related bug, not a Nova one
Comment 3 Jason Guiditta 2013-12-04 17:34:25 EST
https://github.com/redhat-openstack/astapor/pull/67

Merged to master
Comment 6 Scott Lewis 2013-12-13 09:41:28 EST
Adding FutureFeatures to RHOS 4 feature tracker
Comment 7 Jason Guiditta 2013-12-13 10:24:09 EST
Text updated.
Comment 8 Bruce Reeler 2013-12-15 23:29:18 EST
Doc text OK. Thx.
Comment 9 Crag Wolfe 2013-12-18 17:32:40 EST
Verified that "auto_assign_floating_ip" appear as parameters that can be overidden in Foreman UI for the two Host Groups Compute (Nova Network) and Controller (Nova Network) by clicking on More->Configuration->Host Groups, Compute (Nova Network) or Controller (Nova Network), then the Parameters tab.
Comment 12 errata-xmlrpc 2013-12-19 19:33:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.