Bug 1026555 - [ja_JP] Migrate Instance (in Admin > Instance) does not fit in the pull down menu
[ja_JP] Migrate Instance (in Admin > Instance) does not fit in the pull down ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: Upstream M3
: 5.0 (RHEL 7)
Assigned To: Julie Pichon
Yuko Katabami
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 18:37 EST by Mie Yamamoto
Modified: 2015-02-15 17:02 EST (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-2014.1-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 11:42:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
migrate instance in the pull down menu (172.16 KB, image/png)
2013-11-04 18:37 EST, Mie Yamamoto
no flags Details
Migrate Instance -- box width fixed (141.75 KB, image/png)
2014-03-26 06:11 EDT, Yuko Katabami
no flags Details

  None (edit)
Description Mie Yamamoto 2013-11-04 18:37:34 EST
Created attachment 819419 [details]
migrate instance in the pull down menu

Description of problem:
Migrate instance does not fit in the pulldown menu


Version-Release number of selected component (if applicable):4.0


How reproducible: 100%


Steps to Reproduce:
1.Click on Admin-System Panel-Instances tab from the left side panel
2.Click on the More pull down
3.

Actual results:
Migrate Instance (インスタンスのマイグレーション)

Expected results:
インスタンスの移行? can be used to make it a little shorter.


Additional info:
Comment 2 Yuko Katabami 2013-11-10 16:03:32 EST
Reported to the upstream ja-JP user group on 8 Nov and is currently under discussion.
Comment 3 Julie Pichon 2013-11-13 10:58:24 EST
The button names are auto-generated. If we're happy that the new translation for 'migration' is appropriate in the other places (success/error messages, etc.) this should be doable, otherwise we may have to leave it as in for the time being.
Comment 4 Yuko Katabami 2013-11-13 17:33:27 EST
Translation is unlikely to be changed after discussion with the upstream ja-JP user group because the current translation is more appropriate for other usages (e.g. live migration) and it is better to make it consistent across the entire UI strings.

The string "Migrate Instance" in the dropdown menu is wider than the space provided, however it is not truncated (all characters are still visible).
Also this issue is present in Firefox, but not in Google Chrome.

For those reasons, the priority may not be high, but it would be great if the width can be extended to fit the entire string at some stage.
Comment 5 Julie Pichon 2013-11-14 09:36:21 EST
Thank you for the update, Yuko.
Comment 6 Yuko Katabami 2014-03-26 06:11:52 EDT
Created attachment 878930 [details]
Migrate Instance -- box width fixed
Comment 7 Yuko Katabami 2014-03-26 06:18:52 EDT
During the upstream Icehouse translation review, I found that this issue has been fixed.
I am not sure what status change I should make now, as it is still not pushed into RHEL OSP.

Julie, should I wait until this can be verified in Red Hat version?
Comment 8 Julie Pichon 2014-03-26 06:25:14 EDT
Thanks for the update Yuko, it's good news. I think there are 2 things we can do:

 * Close the bug with "NEXTRELEASE" in the details dropdown menu (and leave a comment indicating this is fixed in RHEL OSP 5.0), or
 * Wait for the RHEL OSP 5 packages to be available and verify on a OSP 5 system.

In general option #2 is preferred but because this is a small, low priority/severity bug I think either is fine here. Let me know. Thank you!
Comment 9 Yuko Katabami 2014-03-26 06:32:49 EDT
Hi Julie,

Thank you for your prompt reply.
I choose option #2.
Comment 10 Julie Pichon 2014-03-26 06:35:42 EDT
Ok! Let's leave the bug open until then. I took the liberty of assigning you to verify it.
Comment 11 Yuko Katabami 2014-03-26 06:37:38 EDT
Nps. Thank you Julie.
Comment 12 Julie Pichon 2014-05-27 05:51:50 EDT
This was fixed during upstream Icehouse and should already be available in our packages.
Comment 16 errata-xmlrpc 2014-07-08 11:42:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0855.html

Note You need to log in before you can comment on or make changes to this bug.