Bug 1026561 - Nautilus crashes on folder removal in browser mode
Nautilus crashes on folder removal in browser mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nautilus (Show other bugs)
6.4
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
:
Depends On:
Blocks: 1271696
  Show dependency treegraph
 
Reported: 2013-11-04 19:48 EST by Emily
Modified: 2016-05-10 21:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 21:11:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix based on current nautilus code, see description (811 bytes, patch)
2013-11-04 19:48 EST, Emily
no flags Details | Diff

  None (edit)
Description Emily 2013-11-04 19:48:38 EST
Created attachment 819428 [details]
Fix based on current nautilus code, see description

Description of problem:
Nautilus can crash in browser mode if a folder that was previously visited and is thus still visible in the location bar gets deleted.

This is caused by a corrupt button entry in the location bar that points to invalid/unmapped memory after a directory present in the location bar got removed. As soon as nautilus traverses the list for whatever reason(there are multiple examples of that in the code), it crashes.

After a bit of investigation, I think that's caused by nautilus-2.31.5-cleanup-pathbar.patch, which tries to fix bug #690147(location bar not updated on folder removal) but fails at doing it properly. I've attached a fixed patch that is based on the current nautilus code[1], nautilus-cleanup-pathbar2.patch. It obseletes nautilus-2.31.5-cleanup-pathbar.patch.

[1] https://git.gnome.org/browse/nautilus/tree/src/nautilus-pathbar.c?id=481cf689488668012ca9d7a9c6b15b1dcd0cb465, line 1539+.

Version-Release number of selected component (if applicable):
2.28.4 / 2.28.4-19-el6 (i686)

How reproducible:
Almost always

Steps to Reproduce:
1. Enable browser mode and make sure the button location bar is active
2. mkdir ~/a/b/c
3. Open ~/a/b/c in nautilus
4. Change back to your home directory by clicking it in the location bar or using Alt+Up
5. Move a to trash by right click->Move to trash

Actual results:
Nautilus crashes most of the time. Sometimes it doesn't, but instead shows a corrupted location bar:
[Username] -> [Empty] -> b -> c
and gets highly unstable after that.


Expected results:
a, b and c removed from location bar, no crash of course.


Additional info:
I'm unable to test this issue on an actual RHEL installation. I'm not a Red Hat customer, and apparently I don't qualify for evaluation due to my e-mail address. So this was tested on a popular RHEL6 rebuild.
However, I highly suspect that this issue also affects RHEL, as the Red Hat specific patch that adds this is also be present there.
Comment 8 errata-xmlrpc 2016-05-10 21:11:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0959.html

Note You need to log in before you can comment on or make changes to this bug.