This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 102659 - evolution get stuck on the send & receive window
evolution get stuck on the send & receive window
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-19 11:51 EDT by Need Real Name
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:01:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bzip2 of an strace on evolution (92.23 KB, application/x-bzip2)
2003-10-01 21:02 EDT, David Kaplan
no flags Details

  None (edit)
Description Need Real Name 2003-08-19 11:51:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
using kernel Linux little.lethalwp 2.4.20-19.9 #1 Tue Jul 15 17:18:13 EDT 2003
i686 i686 i386 GNU/Linux
and glibc-2.3.2-27.9

sometimes, when i press the send & receive mail button, the s&r window appear
and gets stuck, pressing cancel doesn't help.

It seems this happens when evolution gets swapped out on the hdd, then swapped
in again (when asking to re-display evolution)

this is very annoying & it's not easy to trigger, to get rid of the problem i
have to killev & restart it again



Version-Release number of selected component (if applicable):
evolution-1.2.2-5

How reproducible:
Sometimes

Steps to Reproduce:
1.start evolution
2.make it swapped out by running some very big memory eating tasks, (i was
playing with mplayer to see how it works when all overlay slots were used at
that time and did a  for i in `seq 35 `; do ( mplayer -ss 0:0:55 mnk-qa.avi
&>/dev/null & ) ; done ), but i don't recomend this method ;)
3. killall mplayer
4. press send & receive button



Actual Results:  send/receive window appears, and it's stuck

Expected Results:  getting mail from pop

Additional info:
Comment 1 Jeremy Katz 2003-09-02 19:07:22 EDT
I haven't seen this.  Can you get an strace or a backtrace in gdb of what
evolution is doing when this occurs?
Comment 2 David Kaplan 2003-09-29 21:35:14 EDT
I am seeing this identical problem with Redhat 9 and all the updates.  It seems
to have started happening recently.  This could be either because of some update
or because I have recently been doing some memory intensive work that might
cause evolution to swap out to disk.

I will run evolution with strace, but I could probably give better information
if someone gave me a lesson in how strace works and what information is desired.
Comment 3 David Kaplan 2003-09-29 21:49:06 EDT
I tried strace, but I couldn't get evolution to freeze up at that moment and the
file grows fairly quickly so I am a bit worried about leaving it on for long
periods of time.  Is there a way to just save the last so many bytes of information?
Comment 4 David Kaplan 2003-10-01 21:02:44 EDT
Created attachment 94861 [details]
bzip2 of an strace on evolution

This trace is the result of running:

strace -o evo.trace.txt evolution &
Comment 5 David Kaplan 2003-10-01 21:04:21 EDT
I now have an strace of evolution from a time when it runs into the bug that
causes it to hang.  This bug is exceedingly annoying and basically happens every
time I want to do real work.  All I have to do is use up a lot of memory with
another program for a time (it seems to require that I am away from evolution
for at least 5 minutes), and then when I go back to evolution to look at my mail
it is all hung up.  Not only will it not download, but it won't display mail either.
Comment 6 Bill Nottingham 2006-10-18 14:01:19 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.