Bug 1026599 - xfce4-terminal windows reappear on a single desktop on startx restart
xfce4-terminal windows reappear on a single desktop on startx restart
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-terminal (Show other bugs)
19
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
: 1043178 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 22:25 EST by mcl8
Modified: 2014-01-10 20:07 EST (History)
5 users (show)

See Also:
Fixed In Version: xfce4-terminal-0.6.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-22 00:36:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 9732 None None None Never

  None (edit)
Description mcl8 2013-11-04 22:25:34 EST
Description of problem: 
I maintain several virtual desktops in xfce4, with one or more xfce4-terminal windows open in each one.  Despite saving the layout on exiting from xfce4, the terminal windows all reappear on a single virtual desktop when restarting xfce4 (startx).  This has occurred on 3 separate systems, all upgraded from fc17 to fc19.  In fc17, the terminal windows were properly saved and restored to their respective virtual desktops.


Version-Release number of selected component (if applicable):
xfce4-terminal-0.6.2-1.fc19.i686
xfce4-session-4.10.1-1.fc19.i686

How reproducible:
Every time.

Steps to Reproduce:
1. Start xfce4
2. Open several Terminal windows on multiple virtual desktops
3. Exit from xfce4, saving the layout
4. Start xfce4

Actual results:
Terminal windows all appear on one virtual desktop, usually the first.

Expected results:
Terminal windows reappear on their saved virtual desktops

Additional info:
Comment 1 Kevin Fenzi 2013-11-04 22:28:46 EST
This is: https://bugzilla.xfce.org/show_bug.cgi?id=9732
Comment 2 Kevin Fenzi 2013-12-14 12:14:14 EST
*** Bug 1043178 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-12-16 17:34:00 EST
xfce4-terminal-0.6.2-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xfce4-terminal-0.6.2-3.fc20
Comment 4 Fedora Update System 2013-12-16 17:35:06 EST
xfce4-terminal-0.6.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xfce4-terminal-0.6.2-3.fc19
Comment 5 Fedora Update System 2013-12-17 14:10:34 EST
Package xfce4-terminal-0.6.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-terminal-0.6.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23501/xfce4-terminal-0.6.2-3.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-12-22 00:36:56 EST
xfce4-terminal-0.6.2-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-12-23 12:55:18 EST
xfce4-terminal-0.6.2-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xfce4-terminal-0.6.2-4.fc19
Comment 8 Fedora Update System 2013-12-27 12:31:05 EST
xfce4-terminal-0.6.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xfce4-terminal-0.6.3-1.fc19
Comment 9 Fedora Update System 2014-01-05 07:34:31 EST
xfce4-terminal-0.6.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.