Bug 1026607 - [UXD] The hovers disappear to quickly.
[UXD] The hovers disappear to quickly.
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Usability (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ER07
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
Depends On: 1015205
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 22:42 EST by Mike Thompson
Modified: 2014-01-02 15:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:42:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Thompson 2013-11-04 22:42:53 EST
Description of problem:
Another team member [who shall remain anonymous -- Jay] complained that the hovers go away too quickly to read the information. 

Version-Release number of selected component (if applicable):JON 3.2.0 ER05


How reproducible:
Always


Steps to Reproduce:
1. Go to monitoring --> metrics 
2. open a graph


Actual results:
Metrics hovers over a bar only stay up for 5 seconds.


Expected results:
Metrics hovers should remain available long enough to read.
Comment 1 Mike Thompson 2013-11-04 22:47:15 EST
I have increased the timeout from 5 seconds to 15 seconds. A timeout is required to keep the hovers from becoming orphaned on a screen refresh. Hovers are activated by onMouseOver, and release by onMouseOut. Now, if a mouseout never occurs and a screen refresh occurs then the hover is left orphaned and *there is no way to get rid of it*. Yes, it stays stuck on your screen. That is why we have the timeout on the hovers.
Comment 2 Mike Thompson 2013-11-04 22:57:11 EST
This was committed to master as: e30123d

Waiting for approval to commit to release/jon3.2.x
Comment 3 Mike Thompson 2013-11-06 23:44:14 EST
This was approved and has been pushed to 
release/jon3.2.x: b9696de
Comment 4 Simeon Pinder 2013-11-19 10:48:09 EST
Moving to ON_QA as available for testing with new brew build.
Comment 5 Simeon Pinder 2013-11-22 00:13:41 EST
Mass moving all of these from ER6 to target milestone ER07 since the ER6 build was bad and QE was halted for the same reason.

Note You need to log in before you can comment on or make changes to this bug.