Bug 102664 - RFE: redhat-control-network can't change profiles as user
Summary: RFE: redhat-control-network can't change profiles as user
Status: CLOSED DUPLICATE of bug 75241
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-network   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-19 16:55 UTC by Dimitri Papadopoulos
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dimitri Papadopoulos 2003-08-19 16:55:13 UTC
Description of problem:
When starting redhat-control-network as a normal user, I am prompted for root
password. It should be possible to disable this behavior.

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.15-1

How reproducible:
Always

Steps to Reproduce:
1.log in as normal user
2.start redhat-control-network
3.try to change profile
    
Actual results:
Prompts for root password.

Expected results:
Should not prompt for root password. Normal users ought to be able to switch
profiles.

Additional info:
As I see it, the point of this GUI tool is to let casual users manage network
connectivity. In some cases, this should include switching profiles, for example
DHCP at home and static IP at ofice. Asking for root password defeats this purpose.

Maybe there could be a checkbox for profiles, similar to the device checkbox:
Allow all users to enable and disable the profile.

Comment 1 Harald Hoyer 2003-08-19 16:58:35 UTC
this is not possible, because it modifies system wide settings and requires root
permissions to do so..
though one can argue, the consoleuser should be able to do so...

Comment 2 Harald Hoyer 2003-12-01 12:55:43 UTC

*** This bug has been marked as a duplicate of 75241 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:58:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.