Bug 1026662 - iLO2 fencing agent test failing
iLO2 fencing agent test failing
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 02:59 EST by combuster
Modified: 2013-11-11 16:25 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 16:25:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description combuster 2013-11-05 02:59:35 EST
Description of problem:

When running Test on iLO2 fencing agent in the Power Management options when editing host properties leads to failure with the message:

"Test Failed, Unable to connect/login to fencing device"

Username and password are correct and I'm able to ssh to the iLO2 from my desktop. I can connect via ssh to iLO2 from the hosts themselves.Both hosts and management server run on CentOS 6.4 with the latest updates. Ovirt server was upgraded from 3.2 to 3.3 a few days back, everything worked out perfectly except for this.

iLO2 is flashed with the latest firmware (a previous release had a bug witch prevented ssh access) so is the entire node. 

Version-Release number of selected component (if applicable):

3.3.0.1-1.el6

How reproducible:

Always

Steps to Reproduce:
1. Configure iLO2 as fencing agent from Power management host options 
2. Press the Test button

Actual results:

"Test Failed, Unable to connect/login to fencing device"

Expected results:

"Test succeded I guess"

Additional info:

Snip from the engine.log (replaced some of the data with * where needed):

2013-11-05 08:42:31,622 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-8) Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Host ovirt-node3* from cluster *_HPBL460c_G6 was choosen as a proxy to execute Status command on Host ovirt-node2*
2013-11-05 08:42:31,624 INFO  [org.ovirt.engine.core.bll.FenceExecutor] (ajp--127.0.0.1-8702-8) Using Host ovirt-node3* from cluster *_HPBL460c_G6 as proxy to execute Status command on Host 
2013-11-05 08:42:31,657 INFO  [org.ovirt.engine.core.bll.FenceExecutor] (ajp--127.0.0.1-8702-8) Executing <Status> Power Management command, Proxy Host:ovirt-node3*, Agent:ilo, Target Host:, Management IP:*, User:*, Options:port=22,secure=false
2013-11-05 08:42:31,689 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (ajp--127.0.0.1-8702-8) START, FenceVdsVDSCommand(HostName = ovirt-node3*, HostId = 402d444c-0f73-43e0-b0c8-226324cd5705, targetVdsId = 793ded19-bb09-456c-bb0b-0ed44b07e956, action = Status, ip = *, port = , type = ilo, user = *, password = ******, options = 'port=22,secure=false'), log id: 42077e7
2013-11-05 08:42:32,224 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-8) Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Power Management test failed for Host ovirt-node2*.Unable to connect/login to fencing device

2013-11-05 08:42:32,227 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (ajp--127.0.0.1-8702-8) FINISH, FenceVdsVDSCommand, return: Test Failed, Unable to connect/login to fencing device
, log id: 42077e7

This is from one of the nodes:

Thread-133459::DEBUG::2013-11-05 08:49:02,699::API::1109::vds::(fenceNode) fenceNode(addr=*,port=,agent=ilo,user=*,passwd=XXXX,action=status,secure=,options=ipport=22
ssl=no)
Thread-133459::DEBUG::2013-11-05 08:49:02,917::API::1135::vds::(fenceNode) rc 1 in agent=fence_ilo
ipaddr=*
login=*
option=status
passwd=XXXX
ipport=22
ssl=no out  err Unable to connect/login to fencing device
Comment 1 combuster 2013-11-05 04:36:53 EST
Hm, furthermore, when I manually run fence_ilo script from either of the nodes in the cluster i get "Status: ON" message. Works with or without ssl..

Heh, just crossed my mind, with fence_ilo script i havent supplied the default ssh port and it worked. When I passed 22 port as an argument it didnt.

So I erased 22 in port option and test succeded, on.

Now I can't recall whether 22 port was there by default or I entered it manually, anyway this is not a bug, maybe just a little confusing why there is such an option and when you supply correct value it refuses to connect.

Sorry for reporting this maybe too soon...
Comment 2 Eli Mesika 2013-11-11 16:25:57 EST
closed due to comment 1

Note You need to log in before you can comment on or make changes to this bug.