Bug 1026724 - python-tg-devtools-2.3.11 is available
python-tg-devtools-2.3.11 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-tg-devtools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 05:05 EST by Upstream Release Monitoring
Modified: 2018-03-20 14:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-tg-devtools-2.3.11-1.fc27
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-20 14:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.28 KB, patch)
2016-08-11 20:32 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.29 KB, patch)
2016-12-04 19:23 EST, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2013-11-05 05:05:11 EST
Latest upstream release: 2.3.1
Current version/release in Fedora Rawhide: 2.3.0-0.4.fc20
URL: https://pypi.python.org/packages/source/t/tg.devtools/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2014-03-11 06:07:30 EDT
Latest upstream release: 2.3.2
Current version/release in Fedora Rawhide: 2.3.0-0.4.fc20
URL: https://pypi.python.org/packages/source/t/tg.devtools/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 2 Upstream Release Monitoring 2014-07-11 04:58:18 EDT
Latest upstream release: 2.3.3
Current version/release in Fedora Rawhide: 2.3.0-0.5.fc21
URL: https://pypi.python.org/packages/source/t/tg.devtools/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 3 Upstream Release Monitoring 2014-10-08 08:11:52 EDT
Latest upstream release: 2.3.4
Current version/release in Fedora Rawhide: 2.3.0-0.5.fc21
URL: https://pypi.python.org/packages/source/t/tg.devtools/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring Soon this service will be implemented by a new system: https://github.com/fedora-infra/anitya/
It will require to manage monitored projects via a new web interface. Please make yourself familiar with the new system to ease the transition.
Comment 4 Upstream Release Monitoring 2015-04-29 09:18:39 EDT
Latest upstream release: 2.3.5
Current version/release in rawhide: 2.3.0-0.5.fc21
URL: https://pypi.python.org/pypi/tg.devtools

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 5 Upstream Release Monitoring 2015-04-29 09:18:50 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-h2Vdoi/python-tg-devtools.spec
return code:  22
stdout:
Getting http://unstable.tg.gy/20130313/tg.devtools-2.3.5.tar.gz to ./tg.devtools-2.3.5.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 6 Upstream Release Monitoring 2015-07-25 20:16:32 EDT
Latest upstream release: 2.3.6
Current version/release in rawhide: 2.3.0-0.6.fc23
URL: https://pypi.python.org/pypi/tg.devtools

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 7 Upstream Release Monitoring 2015-07-25 20:16:43 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-IBi3GR/python-tg-devtools.spec
return code:  22
stdout:
Getting http://unstable.tg.gy/20130313/tg.devtools-2.3.6.tar.gz to ./tg.devtools-2.3.6.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 8 Upstream Release Monitoring 2015-10-13 20:18:27 EDT
Latest upstream release: 2.3.7
Current version/release in rawhide: 2.3.0-0.6.fc23
URL: https://pypi.python.org/pypi/tg.devtools

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 9 Upstream Release Monitoring 2015-10-13 20:18:35 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-9TyE4h/python-tg-devtools.spec
return code:  22
stdout:
Getting http://unstable.tg.gy/20130313/tg.devtools-2.3.7.tar.gz to ./tg.devtools-2.3.7.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 10 Upstream Release Monitoring 2016-03-06 19:18:41 EST
Latest upstream release: 2.3.8
Current version/release in rawhide: 2.3.0-0.7.fc24
URL: https://pypi.python.org/pypi/tg.devtools

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 11 Upstream Release Monitoring 2016-03-06 19:18:52 EST
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-ltD2XI/python-tg-devtools.spec
return code:  22
stdout:
Getting http://unstable.tg.gy/20130313/tg.devtools-2.3.8.tar.gz to ./tg.devtools-2.3.8.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 12 Upstream Release Monitoring 2016-08-11 20:31:57 EDT
Latest upstream release: 2.3.9
Current version/release in rawhide: 2.3.0-0.8.fc25
URL: https://pypi.python.org/pypi/tg.devtools

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4050/
Comment 13 Upstream Release Monitoring 2016-08-11 20:32:14 EDT
Patching or scratch build for python-tg-devtools-2.3.0 failed.
Comment 14 Upstream Release Monitoring 2016-08-11 20:32:16 EDT
Created attachment 1190226 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 15 Upstream Release Monitoring 2016-08-11 20:32:17 EDT
Patches were not touched. All were applied properly
Comment 17 Upstream Release Monitoring 2016-12-04 19:23:20 EST
Latest upstream release: 2.3.10
Current version/release in rawhide: 2.3.0-0.8.fc25
URL: https://pypi.python.org/pypi/tg.devtools

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4050/
Comment 18 Upstream Release Monitoring 2016-12-04 19:23:36 EST
Patching or scratch build for python-tg-devtools-2.3.0 failed.
Comment 19 Upstream Release Monitoring 2016-12-04 19:23:38 EST
Created attachment 1227954 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 20 Upstream Release Monitoring 2016-12-04 19:23:40 EST
Patches were not touched. All were applied properly
Comment 21 Upstream Release Monitoring 2017-07-03 20:22:49 EDT
Latest upstream release: 2.3.11
Current version/release in rawhide: 2.3.0-0.9.fc26
URL: https://pypi.python.org/pypi/tg.devtools

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4050/
Comment 22 Upstream Release Monitoring 2017-07-03 20:22:53 EDT
Unable to resolve the hostname for one of the package's Source URLs
Comment 23 Jan ONDREJ 2017-12-10 04:40:20 EST
Please, make an update for Fedora 27. Current Fedora's tg-devtools are broken.
Try these steps to reproduce:

gearbox quickstart test1 -m -n -x
export PYTHONPATH=$(readlink -e .)
gearbox tgshell -c development.ini

Here is error message:

[ondrejj@work test1]$ gearbox tgshell -c development.ini
/usr/lib/python2.7/site-packages/IPython/frontend.py:21: ShimWarning: The top-le
vel `frontend` package has been deprecated since IPython 1.0. All its subpackage
s have been moved to the top `IPython` level.
  "All its subpackages have been moved to the top `IPython` level.", ShimWarning)
Python 2.7.14 (default, Nov  3 2017, 10:55:25)
Type "copyright", "credits" or "license" for more information.

IPython 5.5.0 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.

  All objects from test1.lib.base are available
  Additional Objects:
  wsgiapp    -  This project's WSGI App instance
  app        -  WebTest.TestApp wrapped around wsgiapp
10:37:50,332 ERROR [gearbox] 'global_ns' keyword argument is deprecated, and has
 been removed in IPython 5.0 use `module` keyword argument instead.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gearbox/main.py", line 167, in _run_sub
command
    return cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 137, in run
    return_code = self.take_action(parsed_args) or 0
  File "/usr/lib/python2.7/site-packages/devtools/gearbox/tgshell.py", line 111,
 in take_action
    shell(local_ns=locs, global_ns={})
  File "/usr/lib/python2.7/site-packages/IPython/terminal/embed.py", line 228, i
n __call__
    global_ns=global_ns, compile_flags=compile_flags)
  File "/usr/lib/python2.7/site-packages/IPython/terminal/embed.py", line 267, i
n mainloop
    raise DeprecationWarning("'global_ns' keyword argument is deprecated, and ha
s been removed in IPython 5.0 use `module` keyword argument instead.")
DeprecationWarning: 'global_ns' keyword argument is deprecated, and has been rem
oved in IPython 5.0 use `module` keyword argument instead.

Updating to tg-devtools 2.3.11 fixes this problem.
Comment 24 Kevin Fenzi 2017-12-24 17:54:05 EST
I'm having a lot of problems getting the tests to work in koji. 

Does this scratch build work for you?

https://koji.fedoraproject.org/koji/taskinfo?taskID=23888068
Comment 25 Jan ONDREJ 2017-12-26 11:00:13 EST
(In reply to Kevin Fenzi from comment #24)
> I'm having a lot of problems getting the tests to work in koji. 
> 
> Does this scratch build work for you?
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=23888068

Works well.
Comment 26 Fedora Update System 2017-12-26 14:19:10 EST
python-tg-devtools-2.3.11-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9131bf0a1e
Comment 27 Fedora Update System 2017-12-27 17:37:24 EST
python-tg-devtools-2.3.11-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9131bf0a1e
Comment 28 Fedora Update System 2018-03-20 14:12:28 EDT
python-tg-devtools-2.3.11-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.