Bug 1026755 - CUPS is sending invalid data to Samsung ML2540 (via samba)
CUPS is sending invalid data to Samsung ML2540 (via samba)
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: splix (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On: 1026613
Blocks: 1026753
  Show dependency treegraph
 
Reported: 2013-11-05 06:20 EST by Tim Waugh
Modified: 2015-06-29 08:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1026613
Environment:
Last Closed: 2015-06-29 08:48:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2013-11-05 06:20:28 EST
+++ This bug was initially created as a clone of Bug #1026613 +++

Description of problem:
Attempted to install two different printers to FC20 Beta (Fedora-20-Beta-x86_64-DVD.iso) using cups-bjnp to a Canon MP980 MFP, and both LPD and smb to a Samsung ML2540 laser printer shared from a Windows 8.1 system.

[...]

With Samba through Windows 8.1, the Windows system has been configured to allow anonymous access to the printer and the firewall has been disabled. When the print job is submitted from FC20, the job is received by Windows as indicated in the Printer Status window, and forwarded to the printer connected via USB. The Samsung laser printer spins up and activates the fuser, but draws no paper and spins down.

Version-Release number of selected component (if applicable):
cups 1.7.0
cups-bjnp 1.2.1
cups-libs 1.7.0
cups-pk-helper 0.2.5

How reproducible:
So far, I've only been able to test locally.

Steps to Reproduce:
1. Set up Canon printer on network, and Samsung laser printer shared via Windows 8.1 with both LPD service and anonymous smb access allowed.

2. Add the printers through the CUPS web interface at https://localhost:631 using bjnp, LPD, and smb access.

3. Submit a job to the printers.

Actual results:
Printers indicate they are receiving data, but print jobs are not completed.

Expected results:
Completed print jobs.

Additional info:
The Canon printer works in FC19 using the cups-bjnp package, and configured through the web interface as described above.
Comment 1 Tim Waugh 2013-11-05 07:49:34 EST
Cloned from bug #1026613. Let's concentrate on the Samsung issue here, using Samba.

Could you please follow the troubleshooting procedure outlined here?:
https://fedoraproject.org/wiki/How_to_debug_printing_problems#Printing_troubleshooter
Comment 2 Dan Mossor [danofsatx] 2013-11-06 10:11:03 EST
Was unable to complete the testing as outlined in the Fedora wiki due to bug 1027034 - will attack it again this evening.

One note to add - the system automatically found a networked HP Laserjet 4014n, and I was able to attach it and print to it without issue through the Printer Settings.
Comment 3 Dan Mossor [danofsatx] 2013-11-06 22:51:53 EST
Once official Samsung ML2540 Series PPD was used as the driver, the print job completed successfully. The included Samsung printers within the cups-drivers package does not include the ML2540.

I don't know if the driver can be included with the cups package due to licensing, but it solved this particular bug.
Comment 4 Jiri Popelka 2013-11-07 05:38:33 EST
Where did you get the PPD ?

http://www.openprinting.org/printers/manufacturer/Samsung
doesn't have ML-2540 in its database.
Comment 5 Dan Mossor [danofsatx] 2013-11-07 08:54:01 EST
I pulled the PPD out of the Samsung Printer Driver 1.00.06 for Linux, dated Aug 5, 2013.

I downloaded the tarball from this page: http://www.samsung.com/us/support/owners/product/ML-2545/XAA# And simply dug through it until I found the ML2540 PPD.
Comment 6 Jiri Popelka 2013-11-11 11:07:28 EST
(In reply to Dan Mossor from comment #5)
> I downloaded the tarball from this page:
> http://www.samsung.com/us/support/owners/product/ML-2545/XAA# And simply dug
> through it until I found the ML2540 PPD.

Ah, thanks. I tried that one too but didn't check the noarch directory.

(In reply to Dan Mossor from comment #3)
> I don't know if the driver can be included with the cups package due to
> licensing, but it solved this particular bug.

This PPD requires a rastertosplc filter, which is also part of that tarball (did you install - by running install.sh - the driver ?), but is not open source, so no, there's no way we could include it in any package.
Comment 7 Jiri Popelka 2013-11-11 11:33:51 EST
There however is one way how to have an open-source driver for Samsung ML-2540.
We have a package called splix, which contains open-source drivers for these Samsung printers.

There's a driver for ML-2550 [1], maybe the ML-2540 is not so much different.
If you are willing to help, could you install splix package and try the ML-2550 one ? For example in system-config-printer this driver appears as
'Samsung ML-2550, 2.0.0 [en]'.

Thank you !

[1] http://splix.ap2c.org/
Comment 8 Dan Mossor [danofsatx] 2013-12-15 12:56:40 EST
The splix driver did not work. I tried to print a test page, and the printer spit out a page that simply had this message on it:

INTERNAL ERROR - Please use the proper driver.

     POSITION : 0X0 (0)

     SYSTEM   : h6fw_5.49/x1_op

     LINE     : 180

     VERSION  : SPL 5.49 10-20-2010
Comment 9 Fedora End Of Life 2015-05-29 05:41:39 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2015-06-29 08:48:50 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.