Bug 1026763 - Locale::Maketext interpolating escaped backslashes improperly
Locale::Maketext interpolating escaped backslashes improperly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Locale-Maketext (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 06:43 EST by Petr Pisar
Modified: 2014-07-02 09:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-Locale-Maketext-1.23-293.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1025906
: 1028949 (view as bug list)
Environment:
Last Closed: 2014-07-02 09:35:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 120457 None None None Never

  None (edit)
Description Petr Pisar 2013-11-05 06:43:44 EST
+++ This bug was initially created as a clone of Bug #1025906 +++

Description of problem:
When a literal backslash is in an L10N value, it is treated nonuniformly by the Locale::Maketext::_compile method, as patched by RH in Locale::Maketext::Guts (per https://bugzilla.redhat.com/show_bug.cgi?id=884354).  The result depends on unrelated parts of the string.

[...]

How reproducible:
Always

Steps to Reproduce:
1. Create a language token, whose value is 'Some data\n'
2. Query the language token through Locale::Maketext ($lh->maketext($tag))

Actual results:
'Some data\\n'

Expected results:
'Some data\n'

Additional info:

The behavior changes in the following cases:
1) If the value contains a tokenized field, behavior depends on whether there is a trailing newline:

'[_1]Some data\n' => 'Some data\n'
'[_1]Some data\n'."\n" => 'Some data\\n
'
2) If the escaped backslash is in a function call, it behaves as expected:

'Some data[sprintf,\n]' => 'Some data\n'



NOTE: All of these cases in standard perl (with Locale::Maketext v 1.13 from CPAN) behave exactly the same as each other, and they all produce just a single '\' before the 'n'.


--- Additional comment from Petr Pisar on 2013-11-04 12:16:19 GMT ---

The 'Some data\n' is due to back-porting the fix to perl 5.10.1.

The parameterized case behaves for me differently and is caused by the changes in the fix. Even latest Locale::Maketext is affected.
----

All Fedoras are affected.
Comment 1 Fedora Update System 2013-11-11 05:19:51 EST
perl-Locale-Maketext-1.23-293.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-Locale-Maketext-1.23-293.fc20
Comment 2 Fedora Update System 2014-01-03 03:35:36 EST
perl-Locale-Maketext-1.23-293.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.