Bug 1026766 - Artifacts referenced in eap6-supported-artifacts BOM not available in Maven repository zip
Artifacts referenced in eap6-supported-artifacts BOM not available in Maven r...
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Paul Gier
Nikoleta Ziakova
Russell Dickenson
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 06:50 EST by Nikoleta Ziakova
Modified: 2014-07-03 16:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-03 16:13:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test pom file (40.86 KB, application/xml)
2013-11-05 06:50 EST, Nikoleta Ziakova
no flags Details
Dependency tree (31.25 KB, text/plain)
2013-11-05 06:52 EST, Nikoleta Ziakova
no flags Details
Dependency tree from 6.2.0 Beta (27.46 KB, text/plain)
2013-11-05 09:52 EST, Nikoleta Ziakova
no flags Details

  None (edit)
Description Nikoleta Ziakova 2013-11-05 06:50:31 EST
Created attachment 819679 [details]
Test pom file

All artifacts referenced in eap6-supported-artifacts BOM are available either in EAP Maven repository zip or in central repository. However the dependency tree cannot be resolved using EAP Maven repository zip only. Following dependencies could not be resolved:

commons-digester:commons-digester:jar:1.8
org.springframework:spring-jms:jar:3.0.7.RELEASE
org.springframework:spring-context:jar:3.0.7.RELEASE
org.springframework:spring-tx:jar:3.0.7.RELEASE
net.sf.ehcache:ehcache-core:jar:2.5.1
org.apache.mina:mina-core:jar:2.0.7
org.apache.felix:org.osgi.core:jar:1.2.0 org.apache.felix:org.osgi.compendium:jar:1.2.0
commons-logging:commons-logging-api:jar:1.1
org.apache.geronimo.specs:geronimo-jaxws_2.2_spec:jar:1.0
org.apache.geronimo.specs:geronimo-activation_1.1_spec:jar:1.0.2
org.apache.geronimo.specs:geronimo-jaxb_2.1_spec:jar:1.0
org.apache.geronimo.specs:geronimo-jaxr_1.0_spec:jar:2.0.0
org.apache.geronimo.specs:geronimo-saaj_1.3_spec:jar:1.0.1
org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:jar:1.0.1
stax:stax-api:jar:1.0.1
org.jboss.byteman:byteman:jar:2.1.2
org.jboss.byteman:byteman-submit:jar:2.1.2
jfree:jfreechart:jar:1.0.9
jfree:jcommon:jar:1.0.12
org.jboss.logging:jboss-logging-processor:jar:1.1.0.Final
com.sun.xml.fastinfoset:FastInfoset:jar:1.2.12
org.slf4j:jul-to-slf4j:jar:1.6.4
org.slf4j:log4j-over-slf4j:jar:1.6.4

Attaching test pom file with imported all dependencies defined in eap6-supported-artifacts BOM.
Comment 1 Nikoleta Ziakova 2013-11-05 06:52:21 EST
Created attachment 819682 [details]
Dependency tree

Attaching dependency tree received with enabled central repository.
Comment 2 Nikoleta Ziakova 2013-11-05 08:31:31 EST
This issue did not occur in EAP 6.2.0.Beta -- all artifacts referenced in eap6-supported-artifacts BOM were available in EAP Maven repository zip.
Comment 3 Nikoleta Ziakova 2013-11-05 08:47:02 EST
This is a regression against 6.2.0 Beta release.
Comment 4 Paul Gier 2013-11-05 09:26:17 EST
I don't consider this a blocker because we require Maven central for our quickstarts, and our Maven repo zip is not completely self contained.  It would require a lot of extra manual POM maintenance to completely remove the dependency on Maven central.

I'm surprised that this wasn't the case in 6.2.0.Beta.  Can you attach the dependency tree from 6.2.0.Beta for comparison?
Comment 5 Nikoleta Ziakova 2013-11-05 09:52:16 EST
Created attachment 819809 [details]
Dependency tree from 6.2.0 Beta
Comment 6 Paul Gier 2013-11-07 13:16:12 EST
In the 6.2.0.Beta dep tree it appears there are several transitive dependencies which were not included in the Maven repo zip, so I think this is not a regression.  We don't have any plans to fix this because it involves too much manual maintenance of the POMs for each rebuild.
Comment 8 Paul Gier 2014-07-03 16:13:05 EDT
Closing this as won't fix because our current build process relies on Maven central to be available to users.  It would require too much maintenance effort to try to modify all poms to use only versions available in the zip, and we would end up shipping artifacts in the zip that we don't want to support (for example the geronimo jars and the spring jars).

Note You need to log in before you can comment on or make changes to this bug.