Bug 1026788 - Unexpected characters show up in ranger's interface
Unexpected characters show up in ranger's interface
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ranger (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ben Boeckel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 07:45 EST by Alick Zhao
Modified: 2013-12-13 22:21 EST (History)
2 users (show)

See Also:
Fixed In Version: ranger-1.6.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 05:36:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unexpected characters showing up in ranger's interface (89.16 KB, image/png)
2013-11-05 07:45 EST, Alick Zhao
no flags Details
trash terminal output when quitting ranger (11.25 KB, image/png)
2013-11-05 07:47 EST, Alick Zhao
no flags Details

  None (edit)
Description Alick Zhao 2013-11-05 07:45:49 EST
Created attachment 819715 [details]
unexpected characters showing up in ranger's interface

Description of problem:
Sometimes there are unexpected characters showing up in ranger's interface. Sometimes they will show up at the ranger command line, and interrupt the input. When quitting ranger, paritial directory info is printed to the terminal. The attched screenshots might explain these better.

Version-Release number of selected component (if applicable):
ranger-1.4.2-2.fc19

How reproducible:
Sometimes

Steps to Reproduce:
1. In terminal, type the command 'ranger',
2. Browse to a directory, like /etc/
3. Wait for some time, something like the screenshot appears.

Actual results:
Some texts show up in the current window.

Expected results:
No strange characters should show up.

Additional info:
Comment 1 Alick Zhao 2013-11-05 07:47:16 EST
Created attachment 819716 [details]
trash terminal output when quitting ranger
Comment 2 Ben Boeckel 2013-11-20 23:21:32 EST
Confirmed. Can you try the RPMs from the F19 (or F20) Koji build[1]? The Rawhide build doesn't have the issue at least. It's a big update for F19; I'll leave it in updates-testing for F19 until it gets karma.

[1]http://koji.fedoraproject.org/koji/buildinfo?buildID=479779
Comment 3 Fedora Update System 2013-11-20 23:26:08 EST
ranger-1.6.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ranger-1.6.1-1.fc19
Comment 4 Fedora Update System 2013-11-20 23:26:23 EST
ranger-1.6.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ranger-1.6.1-1.fc20
Comment 5 Branislav Blaškovič 2013-11-22 15:31:32 EST
Testing ranger-1.6.1-1.fc19.noarch and this bug no longer occours.
Even random terminal bells disapeared.

THank you for the update!
Comment 6 Alick Zhao 2013-12-01 07:57:06 EST
ranger-1.6.1-1.fc19 tested and it works for me. This issue no longer occurs.

Thanks for the update!
Comment 7 Fedora Update System 2013-12-03 05:36:36 EST
ranger-1.6.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-12-13 22:21:14 EST
ranger-1.6.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.