Bug 1026800 - installation repository availability not re-checked after networking changes
installation repository availability not re-checked after networking changes
Status: CLOSED DUPLICATE of bug 1030997
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Shea
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 08:15 EST by Karel Volný
Modified: 2013-12-13 11:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 11:23:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-11-05 08:15:01 EST
Description of problem:
If you choose to install e.g. from http, and you do some networking change, the repository availability is not re-checked afterwards.

Version-Release number of selected component (if applicable):
2013-11-05 nightly

How reproducible:
always

Steps to Reproduce:
1. start network installation
2. at the overview screen, go to networking settings
3. just turn the network off, go back to overview
4. try to configure the installation repository
5. turn the network on

Actual results:
there is "Error setting up base repository" and you cannot install
going to repository configuration and confirming the configuration does not help

Expected results:
a) the error about repository config (which you should get after step 3) is more specific to give a clue what is wrong (see bug 1025398)
b) after activating the network in step 5, you can continue the installation without any other magic from user side

Additional info:
Comment 2 David Shea 2013-12-13 11:23:43 EST
I don't think that triggering a recheck on changes in the network is feasible, since there may be intermittent issues that we'd better to ignore, and there may be issues elsewhere in the network unrelated to the network configuration for which we'd also want to recheck.

A better solution would be to recheck uninitialized repositories any time the source spoke is entered and the user hits "Done", regardless of whether the settings were changed. Such a change is handled in bug 1030997

*** This bug has been marked as a duplicate of bug 1030997 ***

Note You need to log in before you can comment on or make changes to this bug.