Bug 1026826 - openshift_facts.rb should not be installed in %{vendor_ruby}facter
openshift_facts.rb should not be installed in %{vendor_ruby}facter
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: UpcomingRelease
Depends On:
Blocks: 1277547
  Show dependency treegraph
 
Reported: 2013-11-05 08:52 EST by Andy Grimm
Modified: 2016-11-07 22:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 16:42:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2013-11-05 08:52:52 EST
The best practice for add-on facter modules is to put them in a separate directory from the facter installation itself, and to use RUBYLIB, LOAD_PATH, or FACTERLIB to load them (as mentioned in http://docs.puppetlabs.com/guides/custom_facts.html ).  The current placement does not allow for openshift_facts to be omitted or overridden, and it is critical for OpenShift Online to do so.  

More context on this: the reason this has come up is that openshift_facts duplicates the data collection done by one of our other cron jobs, but it only stores counts and throws away the actual mappings of gear uuid / uid / state that we need for our monitoring system.  Collecting this data multiple times is very expensive on a busy system.  We would prefer it if such a metadata cache were part of the core node codebase, but since it is not, we need to keep our own cache implementation for now.
Comment 1 Rory Thrasher 2016-02-02 17:18:48 EST
Closed WONTFIX due to discussion with Andy Grimm on priority.

Note You need to log in before you can comment on or make changes to this bug.