Bug 1026841 - virt-install runs anaconda with method= instead of inst.repo=
virt-install runs anaconda with method= instead of inst.repo=
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 09:13 EST by Kamil Páral
Modified: 2014-01-18 13:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-18 13:26:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-11-05 09:13:24 EST
Description of problem:
If I run a command like this:

$ virt-install --name FedoraTest --ram 1024 --disk pool=default,size=10 --location http://dl.fedoraproject.org/pub/alt/stage/20-Beta-RC2/Fedora/x86_64/os/ --initrd-inject ks.cfg --extra-args "ks=file:/ks.cfg"

it starts Anaconda with method=http://dl.fedoraproject.org/pub/alt/stage/20-Beta-RC2/Fedora/x86_64/os/ . method= is obsolete, inst.repo= should be used instead:
http://fedoraproject.org/wiki/Anaconda_Boot_Options

Even though Anaconda tries to hold compatibility, it causes some weird bugs in corner cases, like bug 1026834.

Please start using inst.repo= instead of method= when running Anaconda.

Version-Release number of selected component (if applicable):
virt-install-0.10.0-4.git79196cdf.fc20.noarch
Comment 1 Cole Robinson 2013-11-05 10:51:59 EST
How long has 'inst.repo' actually been available? Since we will need to maintain back compat for old RH distros where it isn't available
Comment 2 Kamil Páral 2013-11-05 11:20:42 EST
Anaconda documentation is a mess (every single page claims that it is outdated). But according to the wiki page history, method= is deprecated (and repo= is available) since June 2008.

The absolutely correct version is inst.repo= (but repo= should currently work as well). The general "inst" prefix is quite new, I think a year or so. If you need this information, please put needinfo on bcl or some other anaconda team member. Thanks.
Comment 3 Cole Robinson 2014-01-18 13:26:24 EST
Fixed upstream now:

commit 073b3a69e38dab0c21d11aff85fa46164825c1ef
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sat Jan 18 13:04:47 2014 -0500

    urlfetcher: Use inst.repo kernel option for new RH distros (bz 1026841)
Comment 4 Cole Robinson 2014-01-18 13:26:56 EST
Since the current situation works fine, and this will hit rawhide within the month, just closing.

Note You need to log in before you can comment on or make changes to this bug.