Bug 1026848 - don't spawn pop-up for .vv file download if console of just one VM is to be opened
don't spawn pop-up for .vv file download if console of just one VM is to be o...
Status: CLOSED DUPLICATE of bug 1026842
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: nobody nobody
Pavel Stehlik
virt
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 09:19 EST by David Jaša
Modified: 2013-11-11 03:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 10:31:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-11-05 09:19:37 EST
Description of problem:
AFAIK the reason to offer .vv file download in pop-up is ability to download multiple files at once. When just a single console is opened, these downsides of pop-up can be avoided by offering the .vv file download from base window:
  * no need to explicitly allow pop-ups from the RHEV-M site (Firefox)
  * no reloads of portal after hitting "console" (IE)
  * no leftover pop-up windows (IE)

Version-Release number of selected component (if applicable):
is21 / rhevm-webadmin-portal-3.3.0-0.31.beta1.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. set up Console Invocation to "Native client"
2. open console to just one VM
3.

Actual results:
.vv file is offered in a pop-up window

Expected results:
.vv file is offered in base window

Additional info:
when multiple VMs are selected, consoles should still open in pop-up windows
Comment 1 Michal Skrivanek 2013-11-07 10:31:28 EST

*** This bug has been marked as a duplicate of bug 1026842 ***

Note You need to log in before you can comment on or make changes to this bug.