Bug 1026872 - text console (tty) keyboard language set incorrectly
text console (tty) keyboard language set incorrectly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 09:59 EST by Kai Engert (:kaie)
Modified: 2013-12-14 22:28 EST (History)
14 users (show)

See Also:
Fixed In Version: systemd-204-18.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-14 22:28:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2013-11-05 09:59:52 EST
I recently installed F19 using the default gnome ISO.
I chose "install language: english" and "keyboard: german (de)".

The automatically set kernel command line contains
  vconsole.keymap=de LANG=en_US.utf8
which looks correct.

However, after starting up, the login prompt at the text console is incorrectly set to US.

I found that file /etc/vconsole.conf contains KEYMAP=us

I think the F19 installed should have set KEYMAP=de

As a result of this bug, typing the password on the text console is difficult!
Comment 1 Kai Engert (:kaie) 2013-11-05 10:26:08 EST
(In reply to Kai Engert (:kaie) from comment #0)
> I found that file /etc/vconsole.conf contains KEYMAP=us
> I think the F19 installed should have set KEYMAP=de

Unfortunately, fixing the above didn't help!
The text console keymap is still set incorrectly after boot.

Updating summary.
Comment 2 David Shea 2013-11-05 10:40:01 EST
How did you set the keyboard layout, with anaconda or with the GNOME configuration tool? Can you test this with the latest F20 Beta? We've made several changes since F19 in the handling of keyboard layouts.
Comment 3 Kai Engert (:kaie) 2013-11-05 10:43:57 EST
(In reply to David Shea from comment #2)
> How did you set the keyboard layout, with anaconda or with the GNOME
> configuration tool? 

I configured it during install, I conclude I have used anaconda.


> Can you test this with the latest F20 Beta? We've made
> several changes since F19 in the handling of keyboard layouts.

I think we have two bugs, the broken F19 system (and I don't know how to fix it), and potentially the installer not setting it correctly in the first place. Right now my priority is the f19 system (but I can test to install a F20 beta VM later).

Can we please answer this question?

On Fedora 19, what's the system component that's responsible to set the correct keyboard map for text consoles?
Comment 4 David Shea 2013-11-05 10:52:45 EST
The data in vconsole.conf is applied to the text consoles by the systemd-vconsole-setup service.
Comment 5 Kai Engert (:kaie) 2013-11-05 10:59:27 EST
(In reply to David Shea from comment #4)
> The data in vconsole.conf is applied to the text consoles by the
> systemd-vconsole-setup service.

I don't have that service on my F19 system
Comment 6 Kai Engert (:kaie) 2013-11-05 11:01:14 EST
(In reply to Kai Engert (:kaie) from comment #5)
> I don't have that service on my F19 system

Sorry, I do have /usr/lib/systemd/system/systemd-vconsole-setup.service
Comment 7 Kai Engert (:kaie) 2013-11-05 11:12:20 EST
$ localectl 
   System Locale: LANG=en_US.utf8
       VC Keymap: de
      X11 Layout: us,de
     X11 Variant: ,

$ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.11.6-201.fc19.x86_64 root=/dev/mapper/luks.... ro rd.luks.uuid=luks... rd.md=0 rd.lvm=0 rd.dm=0 rd.luks.uuid=luks... vconsole.font=latarcyrheb-sun16 vconsole.keymap=de rhgb quiet LANG=en_US.utf8
Comment 8 Zbigniew Jędrzejewski-Szmek 2013-11-18 20:52:01 EST
It seems most likely that you didn't update the dracut image... I'm not sure why that's required, but currently it is.

Installation issue should be fixed in http://cgit.freedesktop.org/systemd/systemd/commit/?id=0732ef7.
Comment 9 Fedora Update System 2013-11-19 23:54:36 EST
systemd-208-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/systemd-208-6.fc20
Comment 10 Fedora Update System 2013-11-23 22:33:26 EST
Package systemd-208-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-208-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21935/systemd-208-6.fc20
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-11-24 18:49:03 EST
systemd-208-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Kai Engert (:kaie) 2013-11-25 16:40:09 EST
This bug was filed against fedora 19, but you only provided a fedora 20 build.

Do you intend to backport?
Comment 13 Zbigniew Jędrzejewski-Szmek 2013-11-25 23:17:20 EST
(In reply to Kai Engert (:kaie) from comment #12)
> Do you intend to backport?
Yes.
Comment 14 Fedora Update System 2013-12-08 22:38:02 EST
systemd-204-18.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/systemd-204-18.fc19
Comment 15 Fedora Update System 2013-12-10 01:13:19 EST
Package systemd-204-18.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-204-18.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23072/systemd-204-18.fc19
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-12-14 22:28:28 EST
systemd-204-18.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.