Bug 1026877 - Agenda View is not showing the data for activations
Agenda View is not showing the data for activations
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Eclipse Tooling (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ER2
: ---
Assigned To: Mario Fusco
Tomas Schlosser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 10:10 EST by Kris Verlaenen
Modified: 2014-08-06 15:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 15:59:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Verlaenen 2013-11-05 10:10:07 EST
When checking activations in the agenda view, the view is only showing the rule name of the activation, not the data associated with it (variables used in the rules etc.).

This is because the method getActivationParameters(..) on AbstractWorkingMemory is not returning the correct information.  It seems to be caused by the changes in the activations (lazy evaluation, etc.).  This method needs to be updated so the agenda view is showing the correct information again.
Comment 2 Edson Tirelli 2013-12-12 09:24:30 EST
Postponed as agreed during the triage call.
Comment 5 Tomas Schlosser 2014-06-06 07:56:10 EDT
Verified with JBTIS 7.0.2.CR1.

Note You need to log in before you can comment on or make changes to this bug.