Bug 1026881 - Ceilometer service configuration fails
Ceilometer service configuration fails
Status: CLOSED WORKSFORME
Product: Fedora EPEL
Classification: Fedora
Component: openstack-puppet-modules (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Magr
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 10:12 EST by Adam Huffman
Modified: 2015-06-10 07:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-10 07:07:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2013-11-05 10:12:04 EST
Description of problem:
When running packstack on a CentOS 6.4 box, with Ceilometer enabled, configuration of the Ceilometer service seems to fail.

Version-Release number of selected component (if applicable):
openstack-packstack-2013.2.1-0.11.dev806.el6.noarch

How reproducible:


Steps to Reproduce:
1. Run packstack 
2.
3.

Actual results:
Other services are configured, but an error message is reported for Ceilometer:


  ERROR : Error appeared during Puppet run: <ip>_ceilometer.pp
Error: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]: Failed to call refresh: ceilometer-dbsync --config-file=/etc/ceilometer/ceilometer.conf returned 1 instead of one of [0]
You will find full trace in log /var/tmp/packstack/20131105-135210-g3mkOy/manifests/<ip>_ceilometer.pp.log
Please check log file /var/tmp/packstack/20131105-135210-g3mkOy/openstack-setup.log for more information

The logs referred to are:

[mNotice: /Firewall[001 mongodb incoming localhost]/ensure: createdESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Agent::Central/Package[ceilometer-agent-central]/ensure: createdESC[0m
ESC[mNotice: /Stage[main]/Mongodb/Package[mongodb-10gen]/ensure: createdESC[0m
ESC[mNotice: /File[/etc/mongod.conf]/ensure: defined content as '{md5}18721b1d34fcb6856f2108ad589130ba'ESC[0m
ESC[mNotice: /Stage[main]/Mongodb/Service[mongodb]/ensure: ensure changed 'stopped' to 'running'ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Package[ceilometer-backend-package]/ensure: createdESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Collector/Package[ceilometer-collector]/ensure: createdESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Api/Package[ceilometer-api]/ensure: createdESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Api/Ceilometer_config[keystone_authtoken/auth_host]/ensure: createdESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Ceilometer_config[DEFAULT/database_connection]/ensure: createdESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.831 28024 INFO ceilometer.storage.impl_mongodb [-] connecting to MongoDB on mongodb://localhost:27017/ceilometerESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 CRITICAL ceilometer [-] could not connect to localhost:27017: [Errno 111] ECONNREFUSEDESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer Traceback (most recent call last):ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer   File "/usr/bin/ceilometer-dbsync", line 10, in <module>ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer     sys.exit(dbsync())ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer   File "/usr/lib/python2.6/site-packages/ceilometer/storage/__init__.py", line 139, in dbsyncESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer     get_connection(cfg.CONF).upgrade()ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer   File "/usr/lib/python2.6/site-packages/ceilometer/storage/__init__.py", line 81, in get_connectionESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer     return get_engine(conf).get_connection(conf)ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer   File "/usr/lib/python2.6/site-packages/ceilometer/storage/impl_mongodb.py", line 76, in get_connectionESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer     return Connection(conf)ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer   File "/usr/lib/python2.6/site-packages/ceilometer/storage/impl_mongodb.py", line 311, in __init__ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer     self.conn = self.CONNECTION_POOL.connect(url)ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer   File "/usr/lib/python2.6/site-packages/ceilometer/storage/impl_mongodb.py", line 161, in connectESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer     safe=True)ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer   File "/usr/lib64/python2.6/site-packages/pymongo/mongo_client.py", line 337, in __init__ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer     raise ConnectionFailure(str(e))ESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer ConnectionFailure: could not connect to localhost:27017: [Errno 111] ECONNREFUSEDESC[0m
ESC[mNotice: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]/returns: 2013-11-05 14:03:16.843 28024 TRACE ceilometer ESC[0m
ESC[1;31mError: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]: Failed to call refresh: ceilometer-dbsync --config-file=/etc/ceilometer/ceilometer.conf returned 1 instead of one of [0]ESC[0m
ESC[1;31mError: /Stage[main]/Ceilometer::Db/Exec[ceilometer-dbsync]: ceilometer-dbsync --config-file=/etc/ceilometer/ceilometer.conf returned 1 instead of one of [0]ESC[0m


Expected results:


Additional info:
Comment 1 Martin Magr 2013-11-06 08:43:20 EST
This sometimes happen when sync_db is run before MongoDB service starts. First time MongoDB starts it's slower because of DB initialization. This has to be fixed on puppetlabs-mongodb level.
Comment 2 Lukas Bezdicka 2015-06-10 07:07:04 EDT
This is an old bug and I'm not aware of any issues with ceilometer now.

Note You need to log in before you can comment on or make changes to this bug.