Bug 102691 - No KDE menu item for xemacs
Summary: No KDE menu item for xemacs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xemacs   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-19 21:36 UTC by Uwe Beck
Modified: 2015-01-08 00:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-16 12:22:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Uwe Beck 2003-08-19 21:36:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [de] (X11; U; Linux 2.4.21-1.1931.2.393.ent i686)

Description of problem:
After installation xemacs-21.4.12-6 there is no menu item in KDE menu. KDE menu
only
contains emacs if it is installed.
Start xemacs from kommandline is o.k..

 

Version-Release number of selected component (if applicable):
xemacs-21.4.12-6

How reproducible:
Always

Steps to Reproduce:
1. Install xemacs
2. Use KDE menu to start, no xemacs item is available
3.
    

Expected Results:  should be insert in KDE menu

Additional info:

Comment 1 Jens Petersen 2003-09-02 06:48:50 UTC
The KDE menu and GNOME menu should be pretty much the same in RHL 9.

You should be able to find XEmacs in:

   Programming -> More Programming Tools -> XEmacs

if not it should be fixed in rawhide and our current betas.

Comment 2 Uwe Beck 2003-09-14 18:52:46 UTC
> The KDE menu and GNOME menu should be pretty much the same in RHL 9.

Sorry, I only install KDE and there is no
 Programming -> More Programming Tools -> XEmacs
Because of this I create this bugreport.

> if not it should be fixed in rawhide and our current betas.

The bug should be fixed in Red Hat 9!
I am try to install xemacs-21.4.13-5.i386.rpm from rawhide. It needs a lot of
other new rpms from rawhide. And the best is xemacs-21.4.13-5.i386.rpm was
compiled with a newer gcc Version than Red Hat 9 contains. At this point I
break.
I install xemacs-21.4.13-5.i386.rpm with --nodeps to see that the menu item
is availible. Yes it is.
xemacs can not be used
 --> xemacs: relocation error: xemacs: symbol sys_siglist, version GLIBC_2.3.3
not defined in file libc.so.6 with link time reference

Sorry, on this way I do not update productiv systems.
Sorry, this is not a correction of a mistake for a Red Hat 9 rpm.

Would it be better if I correct this problem myself?

But I do not understand that it can be so difficult to do the following in the
rpm:

You can find net-xemacs.desktop in directory:
/usr/share/applications/net-xemacs.desktop

net-xemacs.desktop is needed in directory /usr/share/applnk-redhat/Programming
There are links in directory /var/lib/menu/kde/Applications/Programming

cd /var/lib/menu/kde/Applications/Programming
ln -s /usr/share/applications/net-xemacs.desktop net-xemacs.desktop

The end of support for Red Hat 9 is April 30, 2004!


Comment 3 Uwe Beck 2003-09-14 20:32:51 UTC
Here I am again.

You must only do a correction in /usr/share/applications/net-xemacs.desktop

Categories=TextEditor;Development;X-Red-Hat-Extra;Application

to

Categories=TextEditor;Development;X-Red-Hat-Extra;Application;

Link is not works longer since one of the last updates (i see this in
taroon-beta).


Comment 4 Jens Petersen 2003-09-16 12:22:05 UTC
If you would like to use the latest xemacs package with RHL 9 I suggest
you rebuild it from the srpm.  Otherwise please add the semicolon to the
xemacs desktop file by hand as you suggest.  I'm sorry but I don't really
want to do an errata just to add a single semicolon to the desktop file.

The taroon xemacs is on different branch from that in rawhide/Severn, which
as you kindly verified is fixed.

Comment 5 Uwe Beck 2003-09-22 22:09:06 UTC
I have rebuild it from the srpm now. And I can understand your reason.


Note You need to log in before you can comment on or make changes to this bug.