Bug 1026947 - [DWH-SETUP] - Remote db user is incorrectly configured in dwh service
[DWH-SETUP] - Remote db user is incorrectly configured in dwh service
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Jiri Belka
integration
: Regression, Reopened
Depends On: 1045846
Blocks: 3.3rc1
  Show dependency treegraph
 
Reported: 2013-11-05 12:17 EST by Barak Dagan
Modified: 2014-01-21 10:01 EST (History)
11 users (show)

See Also:
Fixed In Version: is28 - rhevm-dwh-3.3.0-26.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
When configuring a remote database, the remote database user was incorrectly configured, so the rhevm-dwh service could not start. The setup now correctly configures the remote database user in the rhevm-dwh properties file, so this error no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 10:01:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installation logs (181.65 KB, application/x-tar-gz)
2013-11-05 12:17 EST, Barak Dagan
no flags Details
rhevm-dwh-setup & ovirt-engine-dwhd logs (3.40 KB, application/x-gzip)
2013-12-11 10:27 EST, Barak Dagan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22486 None None None Never
oVirt gerrit 22524 None None None Never
oVirt gerrit 22538 None None None Never
oVirt gerrit 22546 None None None Never

  None (edit)
Description Barak Dagan 2013-11-05 12:17:33 EST
Created attachment 819902 [details]
installation logs

Description of problem:
DWH service fails to start, using remote DB configuration due to:

2013-11-05 21:01:22|SSGFb0|SSGFb0|SSGFb0|OVIRT_ENGINE_DWH|HistoryETL|Default|6|Java Exception|tRunJob_2|java.lang.RuntimeException:Child job running failed|1
2013-11-05 21:01:22|ETL Service Stopped
2013-11-05 21:01:22|m7O6JS|SSGFb0|SSGFb0|OVIRT_ENGINE_DWH|ParallelRun|Default|6|Java Exception|tJDBCConnection_2|org.postgresql.util.PSQLException:FATAL: password authentication failed for user "engine_history"|1

Version-Release number of selected component (if applicable):
is21

How reproducible:
100%

Steps to Reproduce:
1. install rhevm using remote setup configuration
2. install dwh setup, use "original" role name
3. start dwh service

Actual results:
service fails to start

Expected results:
service starts successfully

Additional info:
Comment 1 Alex Lourie 2013-11-11 06:12:42 EST
please recreate with the last build.
Comment 2 Alex Lourie 2013-11-17 09:33:35 EST
Please reproduce.
Comment 3 Barak 2013-11-24 07:18:00 EST
moving to CLOSED INSUFFICIENT DATA,
Please reopen if needed/reproduced
Comment 4 Barak Dagan 2013-12-11 10:24:39 EST
Still happenes on IS26 (rhevm-dwh-3.3.0-24.el6ev.noarch) - reopened.

rhevm-dwh-setup-2013_12_11_16_57_44.log:
========================================

2013-12-11 16:58:23::DEBUG::common_utils::215::root:: starting ovirt-engine-dwhd
2013-12-11 16:58:23::DEBUG::common_utils::276::root:: executing action ovirt-engine-dwhd on service start
2013-12-11 16:58:23::DEBUG::common_utils::864::root:: Executing command --> '/sbin/service ovirt-engine-dwhd start' in working directory '/etc/yum.repos.d'
2013-12-11 16:58:34::DEBUG::common_utils::906::root:: output = Starting ovirt-engine-dwhd: at Wed Dec 11 16:58:24 IST 2013[FAILED]

ovirt-engine-dwhd.log:
======================

2013-12-11 16:58:24|ETL Service Started
Exception in component tJDBCConnection_1
org.postgresql.util.PSQLException: FATAL: password authentication failed for user "engine_history"
...
Comment 5 Barak Dagan 2013-12-11 10:27:09 EST
Created attachment 835318 [details]
rhevm-dwh-setup & ovirt-engine-dwhd logs
Comment 6 Yaniv Lavi 2013-12-15 08:58:59 EST
Please attach:
/etc/ovirt-engine/ovirt-engine-dwh/Default.properties


and the expected password.



Yaniv
Comment 8 Yaniv Lavi 2013-12-17 07:42:34 EST
So according to the log although user entered user named "remoteuser", "engine_history" is used instead in the dwh properties file.


Yaniv
Comment 11 Jiri Belka 2014-01-16 10:27:00 EST
ok, is32.2. remote installation works with:

# egrep -i '^ovirt.*db' /etc/ovirt-engine/ovirt-engine-dwh/Default.properties 
ovirtEngineHistoryDbDriverClass=org.postgresql.Driver
ovirtEngineHistoryDbJdbcConnection=jdbc\:postgresql\://testovic.rhev.lab.eng.brq.redhat.com\:5432/ovirt_engine_history?stringtype\=unspecified
ovirtEngineHistoryDbUser=remote_engine_history
ovirtEngineHistoryDbPassword=123456
ovirtEngineDbDriverClass=org.postgresql.Driver
ovirtEngineDbJdbcConnection=jdbc\:postgresql\://testovic.rhev.lab.eng.brq.redhat.com\:5432/remoteengine?stringtype\=unspecified
ovirtEngineDbUser=remoteengine
ovirtEngineDbPassword=123456
Comment 13 errata-xmlrpc 2014-01-21 10:01:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0036.html

Note You need to log in before you can comment on or make changes to this bug.