Bug 1026967 - [RFE] No way to create snapshot from shutdown machine in horizon
[RFE] No way to create snapshot from shutdown machine in horizon
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
x86_64 Linux
high Severity medium
: beta
: 4.0
Assigned To: Matthias Runge
Nir Magnezi
: FutureFeature
Depends On:
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-11-05 13:15 EST by Jaroslav Henner
Modified: 2013-12-19 19:34 EST (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-3.el6ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:34:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2013-11-05 13:15:25 EST
Description of problem:
there is a command nova image-create, accepting a server ID. This server can be in SHUTDOWN state, which it becomes after executing halt command. In such state, it is safe to create a snapshot of the disk, but horizon doesn't allow that. It allows to create snapshot probably only on VMs in ACTIVE state.

Version-Release number of selected component (if applicable):
openstack-dashboard-2013.1.4-1.el6ost.noarch
python-django-horizon-2013.1.4-1.el6ost.noarch


How reproducible:
always

Steps to Reproduce:
1. boot a vm
2. halt it
3. try creating snapshot in Horizon

Actual results:
there's no way to do that

Expected results:
success

Additional info:
Comment 2 Matthias Runge 2013-11-14 06:26:57 EST
The bug was filed against grizzly, and the feature is available in havana.
Comment 3 Scott Lewis 2013-11-19 11:54:35 EST
Auto adding >= MODIFIED bugs to beta
Comment 6 Nir Magnezi 2013-12-02 04:09:39 EST
Verified NVR: python-django-horizon-2013.2-5.el6ost.noarch

Verification Steps:
===================
1. Launch an instance.
2. For that instance selet: Shut Off Instance.
3. Take snapshot.

Result:
=======
1. snapshot was successfully taken.
2. Verified that it is possible to launch instances from that snapshot.
Comment 8 Scott Lewis 2013-12-13 09:41:29 EST
Adding FutureFeatures to RHOS 4 feature tracker
Comment 10 errata-xmlrpc 2013-12-19 19:34:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.