Bug 102698 - tcsh globbing fails against large files.
tcsh globbing fails against large files.
Status: CLOSED DUPLICATE of bug 73877
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-19 19:39 EDT by Need Real Name
Modified: 2007-03-27 00:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-08-19 19:39:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030428

Description of problem:
When globbing a directory containing a large file(>2GB) tcsh fails to list the
file. Thus
# ls -la
total 7041792
drwxr-xr-x    2 dgreen   other        4096 Aug 19 16:06 ./
drwx------    5 dgreen   other        4096 Aug 19 16:11 ../
-rwxr-x---    1 dgreen   other      559540 Aug  9 14:44 VXFnogr*
-rwxr-x---    1 dgreen   other      559540 Aug 11 13:14 VXFnogrlarge*
-rw-rw----    1 dgreen   other    306503680 Aug 19 16:04 c2
-rw-rw----    1 dgreen   other    4904058880 Aug 19 16:11 c32
-rw-rw----    1 dgreen   other    613007360 Aug 19 16:04 c4
-rw-rw----    1 dgreen   other    1226014720 Aug 19 16:06 c8
-rw-------    1 dgreen   other    153251840 Aug 10 07:21 core.10839
-rw-r-----    1 dgreen   other        2169 Aug  9 14:44 vxfdefault9

Note the large file, c32 which is just under 5GB.
# echo *
VXFnogr VXFnogrlarge c2 c4 c8 core.10839 vxfdefault9

Note the absence of c32 in the list
# echo c3[123]
echo: No match.
# echo c[34]2
echo: No match.

But
# ls c32
c32

works. Ie, the globbing function fails against large files. If I replace the
above with one of the othr files, everything works. 






Version-Release number of selected component (if applicable):
tcsh 6.10-6

How reproducible:
Always

Steps to Reproduce:
1.See above. Just run tcsh.
 Under bash, everything works as expected.

2.
3.
    

Expected Results:  The globbing should have picked up the large file. It did not.
This means that any globbing fails. Thus
rm * 
will not remove the large file. 
cp * /tmp
will not copy the large file, etc.



Additional info:
Comment 1 Miloslav Trmač 2004-08-17 09:58:38 EDT

*** This bug has been marked as a duplicate of 73877 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.