Bug 1027016 - User's cron entry error out with CROND ORPHAN (no passwd entry)
User's cron entry error out with CROND ORPHAN (no passwd entry)
Status: CLOSED DUPLICATE of bug 738232
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: 6.6
Assigned To: Marcela Mašláňová
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 17:08 EST by hgraham
Modified: 2013-11-06 06:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 06:46:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hgraham 2013-11-05 17:08:46 EST
Description of problem:
When switching from one NIS domain to another the NIS user cronjobs become ophaned saying that there is (no passwd entry). The getent and id commands both accurately produce the user's information. A restart of the crond service is required to get the cronjobs working again.

Both NIS domains have the same information, the user was just moving the NIS master to a different datacenter.



Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 6.4 (Santiago)
ypbind-1.20.4-30.el6.x86_64
cronie-1.4.4-7.el6.x86_64


How reproducible:
Switching NIS domain binding from one NIS domain to another NIS domain


Steps to Reproduce:
1. Prepare two NIS servers in your test lab for a NIS client to switch in between. 
2. Change the NIS domain binding

Actual results:

NIS user cronjobs do not run and produce the following errors for the NIS users

Oct 31 11:51:01 servername crond[####]: (username1) ORPHAN (no passwd entry)
Oct 31 11:51:01 servername crond[####]: (username2) ORPHAN (no passwd entry)


Expected results:

The cronjobs for the users keep working

Additional info:
Comment 2 Marcela Mašláňová 2013-11-06 06:46:43 EST

*** This bug has been marked as a duplicate of bug 738232 ***

Note You need to log in before you can comment on or make changes to this bug.