Bug 1027023 - Create Project description field validates only after user has pressed save
Create Project description field validates only after user has pressed save
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Alex Eng
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 18:10 EST by Damian Jansen
Modified: 2015-07-30 21:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 21:26:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-11-05 18:10:16 EST
Description of problem:
The Description field in the Create Project page is restricted to 1-100 characters.
This rule is not indicated to the user and validation only occurs after the user has pressed Save

Version-Release number of selected component (if applicable):
3.x

How reproducible:
Easy always

Steps to Reproduce:
1. Sign in, go to Projects
2. Click Create Project
3. Enter > 100 characters in the Description field
4. Click somewhere to defocus the field
    - Note no error is displayed
5. Enter a project id and name, press Save

Actual results:
"size must be between 0 and 100" error is displayed

Expected results:
This error should be displayed to the user before pressing Save, and perhaps a (i) icon indicating the rule should be present.

Additional info:
Comment 1 David Mason 2013-11-05 19:19:39 EST
I also suggest that we label this field as "short description", since they can enter longer descriptive text in the project homepage field.
Comment 2 Luke Brooker 2013-11-05 19:38:15 EST
In the future, I don't think we should have a long description fields, or an kind of wysiwyg. They can use the project url to link to more info if needed or add another url in the short description.
Comment 3 Ding-Yi Chen 2013-11-05 19:51:59 EST
I was going to suggest that "Summary" will be better. Both then we have to either modify the parameter name of desc to summary, or mend the client help.
Comment 4 Alex Eng 2014-06-17 23:09:11 EDT
Is this issue still occuring in 3.4.x?
Comment 5 Damian Jansen 2014-07-28 01:49:37 EDT
Tested 3.5.0-SNAPSHOT (git-server-3.4.2-201-ge0afdde) - still an issue
Comment 6 Alex Eng 2015-05-31 21:07:19 EDT
Pull request:
https://github.com/zanata/zanata-server/pull/836
Comment 7 Zanata Migrator 2015-07-30 21:26:16 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-504

Note You need to log in before you can comment on or make changes to this bug.