Bug 1027026 - [abrt] testdisk-6.14-1.fc20: recover_EXT2: Process /usr/bin/testdisk was killed by signal 8 (SIGFPE)
[abrt] testdisk-6.14-1.fc20: recover_EXT2: Process /usr/bin/testdisk was kill...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: testdisk (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christophe GRENIER
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:1b150f40c21173a969baa046c84...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 18:15 EST by D. Charles Pyle
Modified: 2013-11-17 02:03 EST (History)
1 user (show)

See Also:
Fixed In Version: testdisk-6.14-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-17 02:02:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.29 KB, text/plain)
2013-11-05 18:15 EST, D. Charles Pyle
no flags Details
File: cgroup (159 bytes, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details
File: core_backtrace (2.61 KB, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details
File: dso_list (1.18 KB, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details
File: environ (2.03 KB, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details
File: maps (5.90 KB, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details
File: open_fds (382 bytes, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details
File: proc_pid_status (912 bytes, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details
File: var_log_messages (29 bytes, text/plain)
2013-11-05 18:16 EST, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2013-11-05 18:15:52 EST
Description of problem:
This problem so far has been 100% reproducible.

1.  Run testdisk to try to recover a partition.
2.  The process runs to around 87%
3.  testdisk crashes at around 87%, throwing this error.

Also accompanying the error was an SELinux denial when it tried to write to the system log.

I set enforcing to 0 and the SElinux error does not occur but the app still crashes whether I choose to have it log what it finds or not.  It finds the lost partition and even gives the correct name in the first output but the application never finishes without crashing out and I cannot recover the lost data because the application never gets to that point.

It is something that keeps throwing arithmetic exceptions involving recovery of ext2.  I am not using it to recover ext2, just ntfs, HFS+ and EFI, so I am not sure why I am seeing that.

Version-Release number of selected component:
testdisk-6.14-1.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        testdisk
crash_function: recover_EXT2
executable:     /usr/bin/testdisk
kernel:         3.11.6-301.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (8 frames)
 #0 recover_EXT2 at ext2.c:149
 #1 search_type_2 at analyse.c:269
 #2 search_part at godmode.c:740
 #3 interface_recovery at godmode.c:1304
 #4 menu_disk_ncurses at tdiskop.c:160
 #5 menu_disk at tdiskop.c:203
 #6 testdisk_disk_selection_ncurses at tdisksel.c:199
 #7 do_curses_testdisk at tdisksel.c:266
Comment 1 D. Charles Pyle 2013-11-05 18:15:57 EST
Created attachment 820067 [details]
File: backtrace
Comment 2 D. Charles Pyle 2013-11-05 18:16:00 EST
Created attachment 820068 [details]
File: cgroup
Comment 3 D. Charles Pyle 2013-11-05 18:16:02 EST
Created attachment 820069 [details]
File: core_backtrace
Comment 4 D. Charles Pyle 2013-11-05 18:16:05 EST
Created attachment 820070 [details]
File: dso_list
Comment 5 D. Charles Pyle 2013-11-05 18:16:08 EST
Created attachment 820071 [details]
File: environ
Comment 6 D. Charles Pyle 2013-11-05 18:16:10 EST
Created attachment 820072 [details]
File: limits
Comment 7 D. Charles Pyle 2013-11-05 18:16:13 EST
Created attachment 820073 [details]
File: maps
Comment 8 D. Charles Pyle 2013-11-05 18:16:16 EST
Created attachment 820074 [details]
File: open_fds
Comment 9 D. Charles Pyle 2013-11-05 18:16:18 EST
Created attachment 820075 [details]
File: proc_pid_status
Comment 10 D. Charles Pyle 2013-11-05 18:16:20 EST
Created attachment 820076 [details]
File: var_log_messages
Comment 11 Fedora Update System 2013-11-07 12:34:56 EST
testdisk-6.14-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/testdisk-6.14-2.fc19
Comment 12 Fedora Update System 2013-11-07 12:35:07 EST
testdisk-6.14-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/testdisk-6.14-2.fc20
Comment 13 Fedora Update System 2013-11-07 23:37:24 EST
Package testdisk-6.14-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing testdisk-6.14-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20914/testdisk-6.14-2.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-11-17 02:02:21 EST
testdisk-6.14-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-11-17 02:03:19 EST
testdisk-6.14-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.