Bug 1027033 - Zero width non breaking space in project description causes an exception when opening the project
Zero width non breaking space in project description causes an exception when...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
development
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.7
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On: 1198433
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 18:26 EST by Damian Jansen
Modified: 2015-07-21 22:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-21 22:20:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test run log file (122.29 KB, text/x-log)
2013-11-05 18:30 EST, Damian Jansen
no flags Details

  None (edit)
Description Damian Jansen 2013-11-05 18:26:41 EST
Description of problem:
If the user manages to copy a ZWNBS into their new project description, it will save fine but then fail with an exception when displaying the project.

Version-Release number of selected component (if applicable):
3.x

How reproducible:
Moderate always

Steps to Reproduce:
1. Sign in, go to Projects->Create New Project
2. Enter a valid project id, project name
3. Enter some text into the description, including a ZWNBS (uc. 0xFEFF)
4. Press Save

Actual results:
An exception is thrown

Expected results:
The character should be rejected, or otherwise handled gracefully

Additional info:
The project is actually saved, and shows in the list, but is inaccessible.
Comment 1 Damian Jansen 2013-11-05 18:30:18 EST
Created attachment 820078 [details]
Test run log file

Attach (tail -n 1000 of) the test log
Comment 2 Sean Flanigan 2013-11-05 23:46:47 EST
Caused by: line 1:1: unexpected char: 0xFEFF
	at org.jboss.seam.text.SeamTextLexer.nextToken(SeamTextLexer.java:230) [jboss-seam-2.3.1.Final.jar:2.3.1.Final]

Ah, SeamText is exploding again.  Fantastic.

That's on line 1, so in this case it's probably meant to be acting as a BOM (Byte Order Mark).
Comment 3 Alex Eng 2014-05-27 20:51:01 EDT
Issue should be fixed in 3.4.1. Please retest this.
Comment 4 Ding-Yi Chen 2014-05-28 20:30:39 EDT
Tested with: 
Zanata 3.4.2-SNAPSHOT (git-server-3.4.1-1-g722ff43) 
Zanata 3.5.0-SNAPSHOT (git-server-3.4.1-36-gd5f92ff)

After inserting 0xFEFF in About and Saved, About is not shown.

Steps:
1. Login as a project maintainer or admin.
2. Go to a the project that you can maintain
3. Click Setting - > About (at buttom of Permissions)
4. Type "Test ZWNBS", and paste a ZWNBS from gucharmap
5. Save notes
6. Click About tab on the right of Maintainers

Actual:
About Page was empty.

Expected:
"Test ZWNBS" should be shown.
Comment 5 Alex Eng 2015-05-12 19:46:37 EDT
Ding, 

Just tested in Zanata 3.7, seems working fine now. Can you please retest this?
Comment 6 Ding-Yi Chen 2015-05-12 21:11:32 EDT
Let's wait until Bug 1198433 Verified.
Comment 7 Ding-Yi Chen 2015-05-31 22:48:01 EDT
Seem to fixed as a by-product of Bug 1198433.
Comment 8 Ding-Yi Chen 2015-05-31 22:56:05 EDT
The bug was no longer reproducable with Zanata 3.7.0-SNAPSHOT (git-jenkins-zanata-server-build-integration-master-5281)
Comment 9 Sean Flanigan 2015-05-31 23:57:39 EDT
This would have been fixed by the removal of Seam Text in 3.7, so I want to mark it as RELEASE_PENDING for now.  Bugzilla won't let me do that from the CLOSED state, which is why I'm reopening.
Comment 10 Ding-Yi Chen 2015-06-01 00:04:54 EDT
For better tracking, I set the target-release 3.7

Note You need to log in before you can comment on or make changes to this bug.