Bug 1027089 - Attempt to run puppet apply --verbose configure_origin.pp fails with Invalid parameter node_fqdn at /tmp/configure_origin.pp:47 on node broker.example.com
Attempt to run puppet apply --verbose configure_origin.pp fails with Invalid ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 01:44 EST by Jan Pazdziora
Modified: 2015-05-14 22:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:46:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2013-11-06 01:44:37 EST
Description of problem:

I try to install OpenShift Origin on Fedora 19 using the documentation at http://openshift.github.io/documentation/oo_deployment_guide_puppet.html#configuring-an-all-in-one-host

The puppet apply --verbose configure_origin.pp command fails.

Version-Release number of selected component (if applicable):

openshift/openshift_origin puppet modules as of today.

How reproducible:

Deterministic.

Steps to Reproduce:
1. Follow http://openshift.github.io/documentation/oo_deployment_guide_puppet.html
2. Get to the point when you run 

puppet apply --verbose configure_origin.pp

Actual results:

# puppet apply --verbose configure_origin.pp
Info: Loading facts in /etc/puppet/modules/stdlib/lib/facter/pe_version.rb
Info: Loading facts in /etc/puppet/modules/stdlib/lib/facter/root_home.rb
Info: Loading facts in /etc/puppet/modules/stdlib/lib/facter/facter_dot_d.rb
Info: Loading facts in /etc/puppet/modules/stdlib/lib/facter/puppet_vardir.rb
Error: Invalid parameter node_fqdn at /tmp/configure_origin.pp:47 on node broker.example.com
Error: Invalid parameter node_fqdn at /tmp/configure_origin.pp:47 on node broker.example.com

Expected results:

No error, OpenShift Origin installed.

Additional info:
Comment 2 Luke Meyer 2013-11-14 08:37:30 EST
The puppet parameters have changed. Try the guide again; it's been updated in the last couple days. However, I can't guarantee that everything will work anyway.
Comment 3 Jan Pazdziora 2013-11-20 02:24:30 EST
(In reply to Luke Meyer from comment #2)
> The puppet parameters have changed. Try the guide again; it's been updated
> in the last couple days. However, I can't guarantee that everything will
> work anyway.

Thank you for the heads up. Now the puppet apply run with just the following warnings/errors:

Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Notice: Scope(Class[Ntp]): autoupdate parameter has been deprecated and replaced with package_ensure.  Set this to latest for the same behavior as autoupdate => true.

[...]

Error: Could not find command '/usr/bin/htpasswd'
Error: /Stage[main]/Openshift_origin::Plugins::Auth::Htpasswd/Exec[set first OpenShift user password]/returns: change from notrun to 0 failed: Could not find command '/usr/bin/htpasswd'

[...]

Warning: Augeas[network-scripts](provider=augeas): Loading failed for one or more files, see debug for /augeas//error output

When attempting to access the console then, I see

[Wed Nov 20 02:05:38.331456 2013] [authn_file:error] [pid 32188] (2)No such file or directory: [client 127.0.0.1:15345] AH01620: Could not open password file: /etc/openshift/htpasswd

and I cannot log in.

Also, it seems strange that the original install_repo is no longer listed / shown in the configure_origin.pp template on that page. The installation on Fedora 19 proceeded fine so I assume some repo was used fine but since the page

   http://openshift.github.io/documentation/oo_deployment_guide_puppet.html

starts with

   The OpenShift Origin RPMs can be available from:

listing various repositories, it might be good to show what values should be specified for the values shown in

    http://openshift.github.io/documentation/oo_deployment_guide_puppet.html#install_method
Comment 4 Jan Pazdziora 2013-11-20 22:38:13 EST
(In reply to Jan Pazdziora from comment #3)
> 
> Error: Could not find command '/usr/bin/htpasswd'
> Error: /Stage[main]/Openshift_origin::Plugins::Auth::Htpasswd/Exec[set first
> OpenShift user password]/returns: change from notrun to 0 failed: Could not
> find command '/usr/bin/htpasswd'

[...]

> [Wed Nov 20 02:05:38.331456 2013] [authn_file:error] [pid 32188] (2)No such
> file or directory: [client 127.0.0.1:15345] AH01620: Could not open password
> file: /etc/openshift/htpasswd
> 
> and I cannot log in.

When I install /usr/bin/htpasswd (== httpd-tools-2.4.6-2.fc19.x86_64) manually, the puppet error changes to

Notice: /Stage[main]/Openshift_origin::Plugins::Auth::Htpasswd/Exec[set first OpenShift user password]/returns: /usr/bin/htpasswd: cannot modify file /etc/openshift/htpasswd; use '-c' to create it
Error: /usr/bin/htpasswd -b /etc/openshift/htpasswd openshift password returned 1 instead of one of [0]
Error: /Stage[main]/Openshift_origin::Plugins::Auth::Htpasswd/Exec[set first OpenShift user password]/returns: change from notrun to 0 failed: /usr/bin/htpasswd -b /etc/openshift/htpasswd openshift password returned 1 instead of one of [0]

and the access to the console still fails

[Wed Nov 20 22:12:48.626005 2013] [authn_file:error] [pid 3943] (2)No such file or directory: [client 127.0.0.1:24383] AH01620: Could not open password file: /etc/openshift/htpasswd
Comment 6 Shabna 2013-12-03 01:42:54 EST
Hi 

I am alos facing the same issue following the latest guide
http://openshift.github.io/documentation/oo_deployment_guide_puppet.html#enterprise-prerequisites

I am trying origin install in ec2 (RHEL6)

while running 
puppet apply --verbose configure_origin.pp

I hit a lot of errors 
Error: Could not find command '/usr/bin/htpasswd'
Error: /Stage[main]/Openshift_origin::Plugins::Auth::Htpasswd/Exec[set first OpenShift user password]/returns: change from notrun to 0 failed: Could not find command '/usr/bin/htpasswd'
^C
^CExiting
Error: /Stage[main]/Openshift_origin::Plugins::Frontend::Apache_mod_rewrite/Package[rubygem-openshift-origin-frontend-apache-mod-rewrite]/ensure: change from absent to present failed: exit


Please help!!!

Shabna
Comment 7 Krishna Raman 2013-12-09 12:19:15 EST
Fixed in https://github.com/openshift/puppet-openshift_origin/pull/126
Comment 8 Jan Pazdziora 2013-12-19 02:47:12 EST
Back to the node_fqdn issue -- when I try to install OpenShift Origin release 2 using the documentation from https://mirror.openshift.com/pub/openshift-origin/release/2/documentation/oo_deployment_guide_puppet.html, the original

Error: Invalid parameter node_fqdn at /tmp/configure_origin.pp:47 on node broker.example.com

is back / still there.

It's primarily caused by the fact that the openshift/openshift_origin is not versioned and since it has changed from the state when release 2 went out, it is now not usable to install release 2.

What is the proper way to install release 2 using puppet?
Comment 9 Jan Pazdziora 2013-12-19 03:30:21 EST
On a related note, I confirm that the htpasswd issue has been fixed in latest puppet content for OpenShift nightly.
Comment 12 chunchen 2014-01-06 02:08:16 EST
It's fixed, try to install OpenShift Origin on Fedora 19 using the documentation at http://openshift.github.io/documentation/oo_deployment_guide_puppet.html, will not meet this errors, please refer to the following results:

# puppet apply --verbose configure_origin.pp | grep -i error
Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Warning: Augeas[network-scripts](provider=augeas): Loading failed for one or more files, see debug for /augeas//error output

Note You need to log in before you can comment on or make changes to this bug.