Bug 1027128 - Quota: Executing quota-remove-xattr.sh to see its usage, actually executes it.
Quota: Executing quota-remove-xattr.sh to see its usage, actually executes it.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: vpshastry
Gowrishankar Rajaiyan
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 03:40 EST by Gowrishankar Rajaiyan
Modified: 2015-05-13 12:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.51rhs
Doc Type: Bug Fix
Doc Text:
Previously, using the -h option on quota-remove-xattr.sh script or using quota-remove-xattr.sh to display the disk quota usage would lead to the script execution. With this update, this issue is fixed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:59:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2013-11-06 03:40:23 EST
Description of problem: It is a common practice to execute just the script or with -h option to see its usage or help. While doing the same with quota-remove-xattr.sh, we see that this script executes itself on the pwd along with its usage.


Version-Release number of selected component (if applicable):
glusterfs-server-3.4.0.38rhs-1.el6rhs.x86_64

How reproducible: 100%


Steps to Reproduce:
1. Execute /usr/libexec/glusterfs/quota/quota-remove-xattr.sh to see usage

Actual results:
[root@server1 ~]# /usr/libexec/glusterfs/quota/quota-remove-xattr.sh 
usage: /usr/libexec/glusterfs/quota/quota-remove-xattr.sh <path>
setfattr: .: Operation not supported
setfattr: ./.ssh: Operation not supported
setfattr: ./.ssh/authorized_keys: Operation not supported
setfattr: ./.ssh/known_hosts: Operation not supported
setfattr: ./install.log: Operation not supported


Expected results: Should show only usage and not be executed.


Additional info:
Comment 3 Vivek Agarwal 2013-11-09 05:05:35 EST
Need a -h option for help
Comment 4 Gowrishankar Rajaiyan 2013-12-22 23:41:08 EST
[root@rhss4 ~]# /usr/libexec/glusterfs/quota/quota-remove-xattr.sh 
usage: /usr/libexec/glusterfs/quota/quota-remove-xattr.sh <path>
[root@rhss4 ~]# /usr/libexec/glusterfs/quota/quota-remove-xattr.sh -h
usage: /usr/libexec/glusterfs/quota/quota-remove-xattr.sh <path>
[root@rhss4 ~]# 


[root@rhss4 ~]# gluster --version
glusterfs 3.4.0.51rhs built on Dec 18 2013 11:15:39
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@rhss4 ~]#
Comment 5 Pavithra 2014-01-08 01:42:15 EST
Can you please verify the doc text for technical accuracy?
Comment 6 vpshastry 2014-01-08 01:54:08 EST
Doc text looks good.
Comment 8 errata-xmlrpc 2014-02-25 02:59:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.