Bug 102715 - samba spec needs epoch in versioned dependecies
Summary: samba spec needs epoch in versioned dependecies
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-20 08:32 UTC by Warren Togami
Modified: 2014-08-31 23:25 UTC (History)
2 users (show)

Fixed In Version: 3.0.2a-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 22:28:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2004:259 high SHIPPED_LIVE Important: samba security update 2004-07-22 04:00:00 UTC

Description Warren Togami 2003-08-20 08:32:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Requires: pam >= 0.64 %{auth} samba-common = %{version}
Requires: logrotate >= 3.4 initscripts >= 5.54-1

In every case where a version is used within a dependency, an explicit epoch
MUST be listed in order to avoid future epoch promotion problems.  rpm assumes
wrongly the missing epoch of this dependency when the dependency's epoch
increments while version decrements.  In such cases the older package wins the
version comparison, creating either an unsolvable dependency clash or upgrade to
the older version of the package.

Version-Release number of selected component (if applicable):
samba-3.0.0-3beta3

Comment 1 Warren Togami 2004-02-07 10:26:13 UTC
Requires: pam >= 0:0.64 %{auth} samba-common = %{epoch}:%{version}
Requires: logrotate >= 0:3.4 initscripts >= 0:5.54-1

Also... every occurance of "samba-common = %{version}" should become
"samba-common = %{epoch}:%{version}"

No need for package rebuild with these changes, but next time you roll
samba please add.

can I have your permission to checkin these changes?


Comment 2 Jay Fenlason 2004-02-13 18:21:32 UTC
I checked in this fix in HEAD, and modified my local copies for all
other branches.  It's too bad this didn't make it in before 3.0.2, but
it'll be in the next set of packages I build.

Comment 3 Anders Kaseorg 2004-02-17 19:32:53 UTC
This change seems to be making up2date complain: "Unresolvable chain
of dependencies: samba-client-3.0.2-7 requires samba-common =
%{epoch}:3.0.2". I don't know whose bug that is.

By the way, why isn't it 3.0.2-7 instead of 3.0.2? Currently, you can
upgrade samba-common to to a newer release without upgrading samba-client.

Comment 4 Warren Togami 2004-02-17 19:59:34 UTC
Strange... up2date is not expanding the %{epoch} variable?  That isn't
right.  Are you seeing this behavior on FC1 or FC2 test?

http://www.fedora.us/tempspecs/stable/clamav.spec
See this spec for an example of sub-packages that depend on specific
versions of other sub-packages.  You are right that we should probably
add the %{release} too so it requires the exact same revision.  Jay's
choice here.

Comment 5 Anders Kaseorg 2004-02-17 20:13:23 UTC
It's in FC2 test. Should I file an up2date bug?

Comment 6 Jay Fenlason 2004-02-17 22:28:40 UTC
Fixed in 3.0.2a-1, just built for rawhide.

Comment 7 Mark J. Cox 2004-07-22 11:01:04 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2004-259.html



Note You need to log in before you can comment on or make changes to this bug.