This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1027157 - mongo segfaults with an older version of v8
mongo segfaults with an older version of v8
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: mongodb (Show other bugs)
el6
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: jpacner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 04:59 EST by Georgi Georgiev
Modified: 2014-08-31 19:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-10 04:27:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georgi Georgiev 2013-11-06 04:59:59 EST
Description of problem:

Running "mongo" on the command line results in the following:

$ mongo
MongoDB shell version: 2.4.6
Wed Nov  6 17:10:23.726 mongo got signal 11 (Segmentation fault), stack trace:

Wed Nov  6 17:10:23.727 0x58ec66 0x469c6d 0x7f9206b79920 0x53fa69 0x7f920915cb71 0x7f91def34342
 mongo(_ZN5mongo15printStackTraceERSo+0x26) [0x58ec66]
 mongo(_Z12quitAbruptlyi+0x31d) [0x469c6d]
 /lib64/libc.so.6(+0x32920) [0x7f9206b79920]
 mongo(_ZN5mongo10minKeyCallERKN2v89ArgumentsE+0x39) [0x53fa69]
 /usr/lib64/libv8.so.3(+0x1cbb71) [0x7f920915cb71]
 [0x7f91def34342]

Version-Release number of selected component (if applicable):

- mongodb-2.4.6-1.el6.x86_64
- v8-3.3.10-4.el6.x86_64

How reproducible:

Every time


Steps to Reproduce:
1. Run "mongo" in the shell

Actual results:
mongo segfaults (see above)

Expected results:

It doesn't segfault

Additional info:
This got fixed after upgrading v8 to the latest version in EPEL, so a version
requirement in the .spec file would fix the problem.

I.e. upgrading v8 to v8-3.14.5.10-2.el6.x86_64, and the segfault does not
happen anymore.
Comment 1 jpacner 2014-01-08 03:35:59 EST
Let me apologize for the delay. It's fixed now (see commit c7669db).
Comment 2 jpacner 2014-01-08 03:40:43 EST
Build with the fix is mongodb-2.4.6-3.el6 (https://koji.fedoraproject.org/koji/buildinfo?buildID=488601).
Comment 3 Matthias Saou 2014-02-04 04:16:56 EST
I think the latest build is broken. This line in the spec file :

Requires:       v8-3.14.5.10

Should probably this instead :

Requires:       v8 = 3.14.5.10

Even better would be to not be so specific about the version and use >= if any ABI compatible version above the current one is expected to work.
Comment 4 jpacner 2014-02-04 08:49:49 EST
Thanks Matthias for checking the spec file, it should be fixed in build 2.4.6-4. As for the >= specification, I'm not sure how often is v8 released in EPEL, but in SCLs and Fedora it's often broken and therefore until I'm not assured about ABI stability, I'll stick with a fixed version specification. Suggestions and ideas are welcome though!
Comment 5 Georgi Georgiev 2014-02-04 09:59:08 EST
If it's any help, upstream does not like the idea of building against a non-bundled version of v8[1]. So you may consider dropping the v8 dependency altogether.

[1]: https://jira.mongodb.org/browse/SERVER-10282
Comment 6 Matthias Saou 2014-02-04 10:03:46 EST
FWIW, I just pushed an updated mongodb spec file on master restoring EL6 compatibility. I hope I won't have offended anyone by doing so, but I really felt like splitting the efforts between Fedora and EPEL was a shame, since the same spec file was still used for both until quite recently.

Would you mind having a look at the master branch's content? It's 2.4.9-2, and I've rebuilt it for my own internal EL6 repo to start testing soon and use in production very shortly.

The Fedora branch had a few bugfixes made, but was lacking others (this v8 version requirement, the multilib devel package requirement fix). Re-unifying makes the most sense to me.
Comment 7 jpacner 2014-02-07 10:21:56 EST
Thank you Matthias for the changes. I like having spec files unified as well. Now I've rebuilt the package on my machine and it seems to be working.

Regarding the bundled v8, I'd rather avoid using the bundled one and add >= which is what I've done in http://pkgs.fedoraproject.org/cgit/mongodb.git/commit/?h=el6&id=1514678421e4a7f50b51e9af89859f89a7846d70 .
Comment 8 Fedora Update System 2014-08-12 07:14:51 EDT
mongodb-2.4.6-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mongodb-2.4.6-5.el6
Comment 9 Fedora Update System 2014-08-29 15:42:12 EDT
mongodb-2.4.6-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.