Bug 1027171 - remove-brick :- If User executes 'gluster volume remove-brick <vol> <brick> commit' command before 'gluster volume remove-brick <vol> <brick> start' commands; it removes brick and ends in data loss
remove-brick :- If User executes 'gluster volume remove-brick <vol> <brick> c...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1003914
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 05:18 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:47 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003914
Environment:
Last Closed: 2014-11-11 03:24:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-11-06 06:16:25 EST
REVIEW: http://review.gluster.org/6233 (glusterd: Check if remove-brick is already committed or is not started) posted (#1) for review on master by Vijaikumar M (vmallika@redhat.com)
Comment 2 Anand Avati 2013-11-08 05:20:25 EST
REVIEW: http://review.gluster.org/6233 (glusterd: Do not allow remove-brick commit if the bricks are not decommissioned) posted (#2) for review on master by Vijaikumar M (vmallika@redhat.com)
Comment 3 Anand Avati 2013-12-03 21:12:08 EST
COMMIT: http://review.gluster.org/6233 committed in master by Anand Avati (avati@redhat.com) 
------
commit 8e21e00fc662abb4f6556d9a258fa9ec57a20ed0
Author: Vijaikumar M <vmallika@redhat.com>
Date:   Wed Nov 6 16:41:50 2013 +0530

    glusterd: Do not allow remove-brick commit if the bricks are not decommissioned
    
    Change-Id: Ibf47ea848bbb7ae37ccf91c40e5fe0e2338438b7
    BUG: 1027171
    Signed-off-by: Vijaikumar M <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/6233
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
Comment 4 Niels de Vos 2014-09-22 08:32:34 EDT
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 5 Niels de Vos 2014-11-11 03:24:28 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users

Note You need to log in before you can comment on or make changes to this bug.