Bug 1027186 - using CLI it is possible to delete internal repos created for published views
using CLI it is possible to delete internal repos created for published views
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Bryan Kearney
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 05:50 EST by Ales Dujicek
Modified: 2014-02-18 09:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 09:33:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-11-06 05:50:26 EST
Description of problem:

when publishing content definition, new hidden repo is created: ('repo list' does not list it but it is easy to guess its ID)

> repo info --id 6
Couldn't find Repository with id=6
> content definition publish --name def --org torg --view_name testview
Content view [ testview ] published successfully.
> repo info --id 6 -g --noheading
6  repo1 yum  32

and I can delete this repo

> package list --org torg --content_view testview --repo repo1  --product product --noheading
00b1318d-2a4e-4298-8536-7181f442f7e1 pike       pike-2.2-1.noarch.rpm         
07ac1ec3-e01c-4ce4-a090-528580b6b2b3 walrus     walrus-5.21-1.noarch.rpm      
1cb559e1-cbad-46c6-b8b2-e18624db1ae3 gorilla    gorilla-0.62-1.noarch.rpm
...
> repo delete --id 6
Deleted repository '6'
> package list --org torg --content_view testview --repo repo1  --product product --noheading
Could not find repository [ repo1 ] within organization [ torg ], product [ product ], content view [ testview ], and environment [ Library ]

but I think deleting this kind of repositories makes no sense and should not be allowed

Version-Release number of selected component (if applicable):
mdp2 drop 8 - 3
katello-all-1.4.6-61.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
katello-1.4.6-61.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-7.el6sat.noarch
katello-cli-1.4.3-28.el6sat.noarch
katello-common-1.4.6-61.el6sat.noarch
katello-glue-elasticsearch-1.4.6-61.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-6.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-glue-candlepin-1.4.6-61.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.4.3-28.el6sat.noarch
katello-configure-1.4.7-7.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-pulp-1.4.6-61.el6sat.noarch
katello-foreman-all-1.4.6-61.el6sat.noarch

How reproducible:
always
Comment 1 RHEL Product and Program Management 2013-11-06 05:55:50 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Bryan Kearney 2014-02-18 09:33:33 EST
this is against the katello-cli which we are not using any more, closing.

Note You need to log in before you can comment on or make changes to this bug.