Bug 1027258 - Adapt to changes in the redirect URI used by Facebook
Adapt to changes in the redirect URI used by Facebook
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-online-accounts (Show other bugs)
7.0
All All
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 07:42 EST by Debarshi Ray
Modified: 2014-09-13 15:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:02:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 710363 None None None Never

  None (edit)
Description Debarshi Ray 2013-11-06 07:42:01 EST
Due to recent server-side changes made by Facebook, one can not add a Facebook account through the Online Accounts panel.

It fails with the error message: "Authorisation response was: "(null)". This is after logging in successfully, allowing GNOME to read my profile and allowing it to post. As I press "OK" on the last screen, the window closes down and the error message is displayed.
Comment 1 Debarshi Ray 2013-11-06 10:49:26 EST
I built gnome-online-accounts-3.8.5-1.el7:
https://brewweb.devel.redhat.com/taskinfo?taskID=6535849
Comment 5 Martin 2014-01-28 13:38:46 EST
I can't reproduce this bug in gnome-online-accounts-3.8.4.1-2.el7.x86_64 or gnome-online-accounts-3.8.3-1.el7.x86_64

I even tried to remove Gnome application in Facebook settings to go through "allowing GNOME to read my profile and allowing it to post".

Anyway, adding Facebook works in: gnome-online-accounts-3.8.5-5.el7.x86_64
Comment 7 Debarshi Ray 2014-01-30 08:08:39 EST
(In reply to Martin Holec from comment #5)
> I can't reproduce this bug in gnome-online-accounts-3.8.4.1-2.el7.x86_64 or
> gnome-online-accounts-3.8.3-1.el7.x86_64
> 
> I even tried to remove Gnome application in Facebook settings to go through
> "allowing GNOME to read my profile and allowing it to post".

Then, perhaps, Facebook changed their URI again.

As you can see, someone filed an upstream bug report [1] recently and I was able to reproduce it. So something did break at some point, and we fixed the code to be more correct. Therefore I will not worry if the bug has strangely disappeared.

What really matters is that things continue to work today *with* the patch applied. It is important to have the patch applied because it does attempt to make things more correct.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=710363
Comment 8 Martin 2014-01-30 08:52:47 EST
> Adding Facebook works in: gnome-online-accounts-3.8.5-5.el7.x86_64

Patched gnome-online-accounts works for me, no regressions so far.
Comment 9 Ludek Smid 2014-06-13 09:02:32 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.