Bug 1027284 - Fail to search empty string in OpenLdap domain.
Fail to search empty string in OpenLdap domain.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4.0
Assigned To: Martin Perina
infra
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 08:23 EST by Ondra Machacek
Modified: 2016-02-10 14:19 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 06:46:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2013-11-06 08:23:42 EST
Description of problem:
Error appears when trying to search an empty string in OpenLdap domain.

Version-Release number of selected component (if applicable):
is21

How reproducible:
always

Steps to Reproduce:
1. via rhevm-manage-domains add OpenLDAP
2. via REST or via webadmin try to search an emptry string in OpenLDAP
   (api/domains/6272712d-6f70-656e-6c64-61702e726865/users?search=)

Actual results:
Failed to run LDAP query, please check server logs for more info.

Expected results:
list of users

Additional info:
2013-11-06 14:22:19,330 ERROR [org.ovirt.engine.core.bll.adbroker.LDAPTemplateWrapper] (ajp-/127.0.0.1:8702-4) Error in running LDAP query. BaseDN is , filter is (&(&(objectClass=person)) (|(givenname=*)(sn=*)(uid=*)(uid=*))). Exception message is: [LDAP: error code 4 - Sizelimit Exceeded]; nested exception is javax.naming.SizeLimitExceededException: [LDAP: error code 4 - Sizelimit Exceeded]; remaining name ''
2013-11-06 14:22:19,334 ERROR [org.ovirt.engine.core.bll.adbroker.DirectorySearcher] (ajp-/127.0.0.1:8702-4) Failed ldap search server LDAP://brq-openldap.rhev.lab.eng.brq.redhat.com:389 using user test_admin@BRQ-OPENLDAP.RHEV.LAB.ENG.BRQ.REDHAT.COM due to [LDAP: error code 4 - Sizelimit Exceeded]; nested exception is javax.naming.SizeLimitExceededException: [LDAP: error code 4 - Sizelimit Exceeded]; remaining name ''. We should try the next server
Comment 3 Ondra Machacek 2013-11-18 06:46:56 EST
This error appears when there is set bigger limit on openldap server, then
on rhevm-engine side. So closing as not a bug, because it's configuration issue
and it's correct behaviour.

Note You need to log in before you can comment on or make changes to this bug.