Bug 1027292 - Can't create a user with rhevm-shell: User [userName] required for add [NEEDINFO]
Can't create a user with rhevm-shell: User [userName] required for add
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Michael Pasternak
Elena
infra
: AutomationBlocker, AutomationTriaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 08:37 EST by Ohad Basan
Modified: 2016-02-10 14:26 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 10:01:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mpastern: needinfo? (obasan)


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2013-11-06 08:37:05 EST
Description of problem:
Passing an add user command to rhevm-shell including all the required parameters (including --user_name) yields User [userName] required for add
it looks like rhevm-shell ignores the supplied parameter
Comment 2 Michael Pasternak 2013-11-06 09:24:06 EST
i cannot reproduce this:

[RHEVM shell (connected)]# list domains 

id         : 71612e6c-6162-2e74-6c76-2e7265646861
name       : qa.lab.tlv.redhat.com

id         : 696e7465-726e-616c-696e-7465726e616c
name       : internal

    
[RHEVM shell (connected)]# list users --domain-identifier 71612e6c-6162-2e74-6c76-2e7265646861 --query "name=mpastern"

id         : 895a8649-8dcb-4e6b-b609-b407a0549f03
name       : mpastern

[RHEVM shell (connected)]# add user 
correlation_id  domain-id       domain-name     expect          user_name       
[oVirt shell (connected)]# add user --user_name mpastern --domain-id 71612e6c-6162-2e74-6c76-2e7265646861

id         : 895a8649-8dcb-4e6b-b609-b407a0549f03
name       : mpastern
domain-id  : 71612e6c-6162-2e74-6c76-2e7265646861
domain-name: qa.lab.tlv.redhat.com
user_name  : mpastern@qa.lab.tlv.redhat.com

[RHEVM shell (connected)]# remove user mpastern

status-state: complete

[RHEVM shell (connected)]# add user --user_name mpastern@qa.lab.tlv.redhat.com --domain-name qa.lab.tlv.redhat.com --expect '201-created' --correlation_id 324

id         : 895a8649-8dcb-4e6b-b609-b407a0549f03
name       : mpastern
domain-id  : 71612e6c-6162-2e74-6c76-2e7265646861
domain-name: qa.lab.tlv.redhat.com
user_name  : mpastern@qa.lab.tlv.redhat.com

[RHEVM shell (connected)]# remove user mpastern

status-state: complete

[RHEVM shell (connected)]# add user --user_name 'mpastern@qa.lab.tlv.redhat.com' --domain-name 'qa.lab.tlv.redhat.com' --expect '201-created' --correlation_id 324

id         : 895a8649-8dcb-4e6b-b609-b407a0549f03
name       : mpastern
domain-id  : 71612e6c-6162-2e74-6c76-2e7265646861
domain-name: qa.lab.tlv.redhat.com
user_name  : mpastern@qa.lab.tlv.redhat.com

please provide reproducer
Comment 3 Michael Pasternak 2013-11-11 10:01:06 EST
closing this bug, please reopen it if you have reproducer.

Note You need to log in before you can comment on or make changes to this bug.