Bug 1027321 - Account provider: cannot delete any user
Account provider: cannot delete any user
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openlmi-providers (Show other bugs)
7.0
Unspecified Unspecified
high Severity urgent
: rc
: ---
Assigned To: Tomáš Bžatek
Robin Hack
:
Depends On:
Blocks: 922084
  Show dependency treegraph
 
Reported: 2013-11-06 09:53 EST by Petr Sklenar
Modified: 2014-06-17 23:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: openlmi-providers-0.4.1-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:57:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-11-06 09:53:29 EST
Description of problem:
Account provider: cannot delete any user

Version-Release number of selected component (if applicable):
openlmi-0.4.1-1.el7.noarch
openlmi-account-0.4.1-1.el7.x86_64
openlmi-tools-0.9-3.el7.noarch


How reproducible:
always

Steps to Reproduce:
copy &&paste this script:

--------------
import unittest

import lmi.shell as lmishell
import os
import shutil
import threading
import string
import random
import time

from methods import *

HOST =      "localhost"
USER =      os.environ.get("LMI_CIMOM_USERNAME", "root")
PASSWD =    os.environ.get("LMI_CIMOM_PASSWORD", "blank")

def id_generator(size=6, chars=string.ascii_uppercase + string.digits):
   return ''.join(random.choice(chars) for x in range(size))
#setup
conn = lmishell.connect(HOST, USER, PASSWD)
cs = conn.root.cimv2.PG_ComputerSystem.first_instance()
lams = conn.root.cimv2.LMI_AccountManagementService.first_instance()

#create
myuser = "lmishell-user" + id_generator(18)
print myuser
user = lams.CreateAccount(Name=myuser, System=cs)

user_mod = conn.root.cimv2.LMI_Account.first_instance({"Name" : myuser})
grp_mod = conn.root.cimv2.LMI_Group.first_instance({"Name": myuser})
print user_mod.DeleteUser()
print grp_mod.DeleteGroup()
----------------

Actual results:
LMIReturnValue(rval=-1, rparams=NocaseDict({}), errorstr=u'CIM_ERR_FAILED: Lost connection with cimprovagt "cmpiLMI_Account".: \'DeleteUser\'')


cimserver running manually:
cimserver daemon=false forceProviderProcesses=false
<program name unknown>: symbol lookup error: /usr/lib64/cmpi/libcmpiLMI_Account.so: undefined symbol: lu_homedir_remove_for_user_if_owned


Expected results:
pass

Additional info:
Comment 1 Petr Sklenar 2013-11-06 09:56:00 EST
Fyi
tomas bzatek found thats due to my version of:
libuser-0.59-2.el7.x86_64

with libuser-0.60-3.el7 it works fine, please add it into requires
Comment 2 Tomáš Bžatek 2013-11-06 09:56:15 EST
(In reply to Petr Sklenar from comment #0)
> <program name unknown>: symbol lookup error:
> /usr/lib64/cmpi/libcmpiLMI_Account.so: undefined symbol:
> lu_homedir_remove_for_user_if_owned

This is a new symbol in libuser-0.60, need to add explicit Require:
Comment 4 Tomáš Bžatek 2013-11-06 12:23:20 EST
Fixed in openlmi-providers-0.4.1-2.el7
Comment 6 Ludek Smid 2014-06-13 05:57:36 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.