Bug 1027339 - rhqctl status doesn't report correct PIDs for server and the underlying JVM
rhqctl status doesn't report correct PIDs for server and the underlying JVM
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Launch Scripts (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity medium
: DR01
: JON 3.3.0
Assigned To: Michael Burman
Filip Brychta
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 10:28 EST by Lukas Krejci
Modified: 2014-12-11 09:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:02:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Krejci 2013-11-06 10:28:20 EST
Description of problem:
rhqctl status (--server) is supposed to give me the PID of the script that started the server (on a line called "RHQ Server") and the PID of the JBossAS process that it starts (on a line called "JBossAS Java VM child process").

These two lines report the same PID.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start JON server
2. run  "rhqctl status"

Actual results:
the PIDs of the script and the AS JVM are the same

Expected results:
the PIDs are different and therefore should be reported correctly

Additional info:
Note that this most probably is not a regression from previous releases, because the "rhq-server.sh" script (now located in bin/internal) reports the same result.
Comment 2 Michael Burman 2014-07-03 18:19:08 EDT
The rhq-server.sh was printing the SERVER_PID instead of JVM_PID. Fixed in commit 8983596
Comment 3 Michael Burman 2014-07-04 04:07:29 EDT
Commit is in the master.
Comment 4 Simeon Pinder 2014-07-31 11:51:39 EDT
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993
Comment 5 Filip Brychta 2014-08-05 09:11:31 EDT
Verified on
Version :	
3.3.0.DR01
Build Number :	
6468454:dda0a47

Note You need to log in before you can comment on or make changes to this bug.