Bug 1027367 - When using the jsf2 flashscope with faces-redirect=true, pages residing in different directories cannot retrieve the value put in the flash before form submission.
When using the jsf2 flashscope with faces-redirect=true, pages residing in di...
Status: CLOSED DUPLICATE of bug 1017242
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JSF (Show other bugs)
6.1.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Stan Silvert
Ron Šmeral
:
Depends On: 1026999
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 11:35 EST by Paul Gier
Modified: 2017-10-09 20:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1026999
Environment:
Last Closed: 2014-07-28 11:39:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gier 2013-11-06 11:35:30 EST
+++ This bug was initially created as a clone of Bug #1026999 +++

See JAVASERVERFACES-2136 (https://java.net/jira/browse/JAVASERVERFACES-2136)

--- Additional comment from Yong Yang on 2013-11-06 04:36:54 EST ---



--- Additional comment from Yong Yang on 2013-11-06 04:38:56 EST ---
Comment 1 Stan Silvert 2013-11-06 13:33:52 EST
You can view all changes for each release here:
https://javaserverfaces.java.net/nonav/2.1/releasenotes.html

We haven't done any JBoss-only changes for the releases we are talking
about, so we can rely on the Mojarra release notes.

It adds up to quite a number of fixes.  However, we can look at these a
little differently than we would a set of fixes we did ourselves.  All
these fixes have been tested by Oracle and also tested "in the wild" for
the past months.  So I don't see it as extremely risky.  As long as TCK
passes then I have pretty high confidence in the integration.
Comment 8 Marek Schmidt 2013-11-14 10:31:50 EST
This issue is wrong.

As has been discussed in the one-off https://bugzilla.redhat.com/show_bug.cgi?id=1026999, the true issue is not JAVASERVERFACES-2136, as that one is fixed already in EAP 6.1.1, but https://java.net/jira/browse/JAVASERVERFACES-2902 "Flash cookie doesn't get proper path for applications on root", which is an already opened https://bugzilla.redhat.com/show_bug.cgi?id=1017242
Comment 9 Ron Šmeral 2014-07-28 11:39:46 EDT
I suggest we close this issue (as duplicate?) as there's no more work to do:
- the actual one-off for 6.1.1 was processed in https://bugzilla.redhat.com/show_bug.cgi?id=1026999,
- the customer case is closed, the duplicate issue https://bugzilla.redhat.com/show_bug.cgi?id=1017242 is already closed and verified in 6.3,
- both latest 6.2 and latest 6.3 are currently at 2.1.28 which contains a fix for this (since 2.1.24).

*** This bug has been marked as a duplicate of bug 1017242 ***

Note You need to log in before you can comment on or make changes to this bug.