Bug 1027378 - [REPORTS-SETUP] - Unable to drop rhevmreports database using command suggested by installer
[REPORTS-SETUP] - Unable to drop rhevmreports database using command suggeste...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Barak Dagan
integration
: Triaged
Depends On:
Blocks: 1027894 3.3snap3
  Show dependency treegraph
 
Reported: 2013-11-06 12:08 EST by Barak Dagan
Modified: 2014-01-21 09:56 EST (History)
7 users (show)

See Also:
Fixed In Version: IS24.2 - rhevm-reports-3.3.0-22.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
The instructions to troubleshoot a failed rhevm-reports installation were incorrect. They have been fixed, and now users are given the correct command to remove the database.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:56:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reports setup log (6.40 KB, text/plain)
2013-11-06 12:08 EST, Barak Dagan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21164 None None None Never
Red Hat Product Errata RHBA-2014:0035 normal SHIPPED_LIVE rhevm-reports 3.3 bug fix and enhancement update 2014-01-21 14:53:30 EST

  None (edit)
Description Barak Dagan 2013-11-06 12:08:28 EST
Created attachment 820583 [details]
reports setup log

Description of problem:

Installation found existing rhevmreports database, and suggested solution, which doesn't work.

Welcome to ovirt-engine-reports setup utility
ERROR: Found the database for ovirt-engine-reports, but could not find the WAR directory!
In order to remedy this situation, please drop the ovirt-engine-reports database by executing:
/usr/bin/dropdb -U engine_reports -h localhost -p 5432 rhevmreports
Error encountered while installing ovirt-engine-reports, please consult the log file: /var/log/ovirt-engine/ovirt-engine-reports-setup-2013_11_06_21_47_05.log


# /usr/bin/dropdb -U engine_reports -h localhost -p 5432 rhevmreports
dropdb: could not connect to database postgres: FATAL:  Ident authentication failed for user "engine_reports"


Version-Release number of selected component (if applicable):
is21

How reproducible:
100%

Steps to Reproduce:
1. start rhevm-reports-set
2. stop installation after reports admin user(s) password (deploying server...)
3. start rhevm-reports-set again

Actual results:
setup fails and suggests not working solution

Expected results:
Suggests working solution

Additional info:

# su postgres
bash-4.1$ psql -c 'drop database rhevmreports'
Comment 1 Yaniv Lavi 2013-11-21 01:57:21 EST
Please submit this patch to ovirt branch as well.


Yaniv
Comment 2 Alex Lourie 2013-11-24 06:48:12 EST
Done
Comment 4 Charlie 2013-11-27 19:49:46 EST
This bug is currently attached to errata RHEA-2013:15115. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 5 Barak Dagan 2013-12-18 07:26:00 EST
verified on is27, rhevm-reports-3.3.0-25.el6ev.noarch

Checking system state...                              [ ERROR ]
ERROR: Found the database for rhevm-reports, but could not find the WAR directory!
In order to remedy this situation, please drop the rhevmreports database. For example, for local controlled and provisioned setup, one could use the following command: 
    su postgres -c 'dropdb rhevmreports'
For other cases, please ask your DBA to remove the aforementioned DB.
Comment 8 errata-xmlrpc 2014-01-21 09:56:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0035.html

Note You need to log in before you can comment on or make changes to this bug.