Bug 1027412 - resource-agents-3.9.2-21.el6_4.8 upate break ocf:heartbeat:IPv6addr resource agent
resource-agents-3.9.2-21.el6_4.8 upate break ocf:heartbeat:IPv6addr resource ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.4
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: David Vossel
Cluster QE
0day
: ZStream
Depends On: 1025909
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 13:48 EST by Jan Kurik
Modified: 2013-12-07 14:36 EST (History)
12 users (show)

See Also:
Fixed In Version: resource-agents-3.9.2-40.el6_5.2
Doc Type: Bug Fix
Doc Text:
Previously, the IPaddr2 agent did not send out unsolicited neighbor advertisements to announce a link-layer address change. Consequently, floating IPv6 addresses, which require this functionality, could not work correctly. To fix this bug, the send_ua internal binary required for IPaddr2 agent to drive IPv6 addresses has been added. As a result, the floating IPv6 addresses now work correctly, and IPv4 addresses are left unaffected by this change.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 19:28:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 637963 None None None Never

  None (edit)
Description Jan Kurik 2013-11-06 13:48:21 EST
This bug has been copied from bug #1025909 and has been proposed
to be backported to 6.5 z-stream (EUS).
Comment 5 michal novacek 2013-11-18 11:21:24 EST
I have verified that ipv6 can be used with
resource-agents-3.9.2-40.el6_5.3.x86_64.

$ rpm -q resource-agents
resource-agents-3.9.2-40.el6_5.3.x86_64

$ ccs -h localhost --addresource ip address="fe80::1800:ff:fe00:45/64" 

$ ccs -h localhost --addservice le-ipv6 domain="le-domain" recovery="relocate"

$ ccs -h localhost --addsubservice le-ipv6 ip ref="fe80::1800:ff:fe00:45/64"

$ ccs -h localhost --lsservices
service: name=le-ipv6, domain=le-domain, recovery=relocate
  ip: ref=fe80::1800:ff:fe00:45/64
resources: 
  ip: address=fe80::1800:ff:fe00:45/64

$ ip -6 a show dev eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
    inet6 2620:52:0:2246:1800:ff:fe00:42/64 scope global deprecated dynamic 
       valid_lft 2591878sec preferred_lft 0sec
    inet6 fe80::1800:ff:fe00:45/64 scope link 
       valid_lft forever preferred_lft forever
    inet6 fe80::1800:ff:fe00:42/64 scope link 
       valid_lft forever preferred_lft forever
Comment 7 errata-xmlrpc 2013-11-21 19:28:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1746.html

Note You need to log in before you can comment on or make changes to this bug.