Bug 1027440 - DHCP not working on OVSIntPort
DHCP not working on OVSIntPort
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openvswitch (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Flavio Leitner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 15:25 EST by IanB
Modified: 2014-01-24 21:22 EST (History)
5 users (show)

See Also:
Fixed In Version: openvswitch-2.0.0-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1053904 1053913 (view as bug list)
Environment:
Last Closed: 2014-01-24 21:21:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifup-ovs with dhcp support for Internal Ports (3.64 KB, text/plain)
2013-11-26 11:44 EST, Flavio Leitner
no flags Details
Patch enabling DHCP support for internal ports (1.35 KB, patch)
2014-01-13 15:46 EST, Flavio Leitner
no flags Details | Diff

  None (edit)
Description IanB 2013-11-06 15:25:40 EST
Description of problem:

Setting a port of TYPE=OVSIntPort to use DHCP is ignored i.e. dhclient is not run for that interface

ifup-ovs script appears to only handle DHCP on TYPE=OVSBridge . Why?


How reproducible:

100%


Steps to Reproduce:

physical interface is 'p1p1' with config:

DEVICE="p1p1"
ONBOOT="yes"
DEVICETYPE="ovs"
TYPE="OVSPort"
OVS_BRIDGE="ovsbr0"
BOOTPROTO="none"
HOTPLUG="no"

bridge interface is 'ovsbr0' with config:

DEVICE="ovsbr0"
ONBOOT="yes"
DEVICETYPE="ovs"
TYPE="OVSBridge"
BOOTPROTO="none"
HOTPLUG="no"

Internet ovs port is 'mgmt0' with config:

DEVICE="mgmt0"
ONBOOT="yes"
DEVICETYPE="ovs"
TYPE="OVSIntPort"
OVSBOOTPROTO="dhcp"
OVSDHCPINTERFACES="p1p1"
OVS_BRIDGE="ovsbr0"
HOTPLUG="no"


Actual results:

I run 'systemctl start network.service' which completes without error, but interface mgmt0 never receives an IP address. Process listing shows no 'dhclient' process running.

Expected results:

dhclient should be started and 'mgmt0' should receive an IP

Additional info:

If I run 'dhclient mgmt0' manually, then 'mgmt0' receives an IP address.
Comment 1 Flavio Leitner 2013-11-26 11:44:02 EST
Created attachment 829364 [details]
ifup-ovs with dhcp support for Internal Ports

It's bug. I don't see a reason to not support it.
Could you backup the original file at
/etc/sysconfig/network-scripts/ifup-ovs

and replace with the attached one for testing purposes?

Thanks!
Comment 2 IanB 2013-11-26 13:53:00 EST
I've tested the attached ifup-ovs script and it works for me. Thanks!
Comment 3 Flavio Leitner 2014-01-13 15:46:47 EST
Created attachment 849626 [details]
Patch enabling DHCP support for internal ports

I've found some issues while reviewing again the previous file.

I came up another better patch which I will post upstream in a few minutes.
Comment 4 Flavio Leitner 2014-01-13 18:59:17 EST
Upstream post: http://openvswitch.org/pipermail/dev/2014-January/035928.html
Comment 5 Flavio Leitner 2014-01-15 09:14:59 EST
Patch accepted upstream.
Comment 6 Fedora Update System 2014-01-15 16:11:46 EST
openvswitch-2.0.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/openvswitch-2.0.0-4.fc20
Comment 7 Fedora Update System 2014-01-15 17:27:29 EST
openvswitch-2.0.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openvswitch-2.0.0-4.fc19
Comment 8 Fedora Update System 2014-01-17 00:52:27 EST
Package openvswitch-2.0.0-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openvswitch-2.0.0-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1014/openvswitch-2.0.0-4.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2014-01-24 21:21:10 EST
openvswitch-2.0.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2014-01-24 21:22:17 EST
openvswitch-2.0.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.