Bug 1027464 - After deleting a snapshot on RAW image, VM won't run
After deleting a snapshot on RAW image, VM won't run
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.5.0
Assigned To: Daniel Erez
Aharon Canan
storage
: Reopened, Triaged
Depends On:
Blocks: rhev3.5beta 1156165
  Show dependency treegraph
 
Reported: 2013-11-06 17:08 EST by Allan Voss
Modified: 2016-02-10 14:34 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-09 10:04:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 533713 None None None Never

  None (edit)
Description Allan Voss 2013-11-06 17:08:41 EST
Description of problem:
After deleting a snapshot on RAW image, VM won't run

Version-Release number of selected component (if applicable):
RHEV-M 3.1, 3.2

How reproducible:
Unknown

Steps to Reproduce:
1. Create Preallocated VM
2. Create snapshot
3. Delete snapshot

Actual results:
VM fails to run (VM starts, but says "No bootable disk". Disk image is shown to have an image size of the full preallocated size, and an actual size of the snapshot that was deleted

Expected results:
VM should run, and image size should be consistent with preallocated image

Additional info:
The actual_size column in the disk_image_dynamic table is updated to reflect the size of the deleted snapshot rather than the size of the preallocated image
Comment 1 Allon Mureinik 2013-11-07 08:16:21 EST
Sergey, please take a look. Doesn't this issue seem similar to an issue you already handled in 3.3?
Comment 3 Sergey Gotliv 2013-11-13 01:39:51 EST
(In reply to Allon Mureinik from comment #1)
> Sergey, please take a look. Doesn't this issue seem similar to an issue you
> already handled in 3.3?
No. I will take a look anyway.
Comment 8 Ayal Baron 2013-11-20 04:55:28 EST
Afaiu we have no idea what's going and no logs to get any such understanding.  We will try to reproduce but probably we'll have to close this bug.
If this happens again, please collect logs as soon as possible.
Comment 9 Allon Mureinik 2013-12-03 04:59:57 EST
(In reply to Ayal Baron from comment #8)
> Afaiu we have no idea what's going and no logs to get any such
> understanding.  We will try to reproduce but probably we'll have to close
> this bug.
> If this happens again, please collect logs as soon as possible.
Unable to reproduce, closing.
Comment 13 Ayal Baron 2014-01-29 08:50:23 EST
Allan, please reopen if this happens again / if you have logs.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.