Bug 102748 - installer hangs when probing sis 650 video card
installer hangs when probing sis 650 video card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 12:04 EDT by Mark Pinto
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 02:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
original made during install (3.08 KB, text/plain)
2003-08-25 23:38 EDT, Mark Pinto
no flags Details
made by redhat-config-xfree86 --reconfig (3.05 KB, text/plain)
2003-08-25 23:39 EDT, Mark Pinto
no flags Details
XFree86 log... (27.56 KB, text/plain)
2003-08-25 23:39 EDT, Mark Pinto
no flags Details

  None (edit)
Description Mark Pinto 2003-08-20 12:04:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030816 Mozilla Firebird/0.6.1+

Description of problem:
i've recently bought a laptop, compaq presario 3017cl.  it comes with
Win XP, so obviously i felt the need to install linux on it right away.
unfortunately, redhat doesnt seem to like my video card.  when doing a
graphical install, everything works fine to the "checking media"
section.  after that, the installer probes my video card and correctly
detects my sis 650 (it's actually an M650..dont know if that matters). however,
as soon as that happens, my screen goes
completely black.  ctrl+alt+f2 sends me to the console, but even then
only the top 1/7th or so of my screen actually works.  the rest is
black.  it's weird, annoying, and i dont like it   let me know if you
need any more information or have any suggestions.  and yes, i'm sure i
probably could do a text install, but this isnt a server so i truly want
a GUI on it.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load up graphical installer
2. Wait 'til after the testing media section
3. 
    

Actual Results:  Froze when probing video card

Expected Results:  Continued on in graphical install mode

Additional info:
Comment 1 Bill Nottingham 2003-08-20 17:34:00 EDT
If you install in text mode, and boot to a text console, and then run 'kudzu -p
-b ddc', does it behave similarly?
Comment 2 Mark Pinto 2003-08-21 19:01:45 EDT
it should be noted that when the cdrom boots and i'm presented with options to
boot into the installer, the redhat logo on top is completely garbled.  also,
once i load into "linux text", my entire screen becomes fuzzy and unpredictable.
 i'm afraid to go forward with the entire text install because i dont know
whatever's causing the 'fuzziness' could damage my monitor if it continues for a
period of time.  suggestions?
Comment 3 Bill Nottingham 2003-08-21 20:44:48 EDT
What happens if you boot with 'linux text nofb'?
Comment 4 Mark Pinto 2003-08-21 21:27:58 EDT
"linux text nofb" worked perfectly and allowed me to do a minimal install.  then
i did kudzu -p -b ddc, which worked fine, but there was one oddity.  for driver
it listed "unknown".  
class: video
bus: ddc
detached: 0
driver: unknown
dec: "silicon integrated systems corp 6325
mem: 65472
Comment 5 Bill Nottingham 2003-08-21 21:30:38 EDT
Does setting XFree86 up post-install work?
Comment 6 Mark Pinto 2003-08-21 21:37:40 EDT
dont know yet.  i was only able to do a minimal install because i lost cd2.  i'm
downloading that right now, so i should be able to post results shortly.  
Comment 7 Mark Pinto 2003-08-22 12:56:30 EDT
i downloaded severn's other cds and did the 'personal desktop' install using
"linux text nofb".  installation went fine.  once rebooted, everything worked
until gdm loaded up.  as soon as that happens, my screen goes
completely black.  ctrl+alt+f2 sends me to the console, but even then
only the top 1/7th or so of my screen actually works.
Comment 8 Bill Nottingham 2003-08-22 13:05:00 EDT
OK, so this is an XFree86 problem on your graphics chipset.
Comment 9 Mark Pinto 2003-08-22 16:52:03 EDT
http://www.xfree86.org/current/sis.4.html
according to this, my card is supported under 4.3.0, but not 4.2.1.  which does
severn use?
also, this seems to explain the same problem i've been having.
http://www.mail-archive.com/xfree86@xfree86.org/msg07345.html
Comment 10 Bill Nottingham 2003-08-22 16:58:02 EDT
Severn uses 4.3.0.
Comment 11 Mike A. Harris 2003-08-24 04:42:27 EDT
The PCI ID of the SiS 650, as listed in our PCI table, is:

0x1039  0x6325  "Card:SiS 650"  "Silicon Integrated Systems
[SiS]|SiS650/651/M650/740 PCI/AGP VGA Display Adapter"

This chip ID is for all of the models listed in the entry above.  The config
tool's Cards database has the following entry for this card.

NAME SiS 650
CHIPSET SiS650
DRIVER sis
NOCLOCKPROBE

This entry is correct.  It seems that the sis driver may be buggy for this
chip.  In order to troubleshoot the problem, I will need you to backup your
current working configuration, disable the framebuffer, and rerun
"redhat-config-xfree86 --reconfig" to change the configuration to use the
automatically detected sis driver.  Please try starting XFree86 after this,
and if it fails, as it should according to your report, please make a backup
copy of the /var/log/XFree86* files, and your /etc/X11/XF86Config* files.
Reconfigure your machine with the known working configuration, and then attach
the requested files individually to the bug report using bugzilla's file
attachment feature.

I'll try to troubleshoot the problem once you've attached these files.

Thanks.
Comment 12 Mark Pinto 2003-08-24 18:58:42 EDT
i dont understand which "known working configuration" you're talking about. 
there is none that i'm aware of.  i've tried twaeking XF86Config manually but
havent had any luck.
Comment 13 Mike A. Harris 2003-08-24 21:01:01 EDT
I misunderstood that you used the linux framebuffer as an alternative.
Just ignore that part then, and run the reconfigure line and provide
the info I requested above.

thanks.
Comment 14 Mark Pinto 2003-08-25 23:38:19 EDT
Created attachment 93921 [details]
original made during install
Comment 15 Mark Pinto 2003-08-25 23:39:04 EDT
Created attachment 93922 [details]
made by redhat-config-xfree86 --reconfig

(yes, it's different than the one made during install)
Comment 16 Mark Pinto 2003-08-25 23:39:35 EDT
Created attachment 93923 [details]
XFree86 log...
Comment 17 Mark Pinto 2003-08-25 23:40:25 EDT
redhat-config-xfree86 --reconfig    caused the same problems as mentioned
before.  i've attached the config files and log
Comment 18 Mike A. Harris 2003-08-26 08:47:58 EDT
Section "Device"
	Identifier  "Videocard0"
	Driver      "svga"
	VendorName  "Videocard vendor"
	BoardName   "SiS 650"
EndSection

That was from the installer?  If so, it is totally invalid as there is no such
driver as "svga".


Section "Device"
	Identifier  "Videocard0"
	Driver      "sis"
	VendorName  "Videocard vendor"
	BoardName   "SiS 650"
EndSection

That one is correct, from redhat-config-xfree86

Comment 19 Mike A. Harris 2003-08-26 08:59:01 EDT
msf/brent/jeremy:  Any of you guys know where "svga" would be coming from
as an invalid driver?  It's not in the hardware database, I just checked.

Aside from that though, this is failing while using the sis driver, which
is the correct driver.  I do not have sis hardware or specifications
unfortunately, so I can't personally debug this problem as direct physical
hardware access is required.  Please report this problem upstream to
XFree86.org at http://bugs.xfree86.org so that the SiS driver maintainer
can investigate this issue.  He has access to SiS hardware and specifications
so he's more likely to be able to resolve the problem.  Once you've reported
the problem upstream, please paste the URL to the upstream report here so
that I can track the issue and possibly backport any fixes that are made.

Comment 20 Mark Pinto 2003-08-26 12:39:46 EDT
http://bugs.xfree86.org/show_bug.cgi?id=627 
Comment 21 Mark Pinto 2003-08-27 14:01:47 EDT
fixed in xfree86 cvs.  hopefully redhat will update their sis driver before 
severn release?
Comment 22 Mike A. Harris 2003-08-28 03:47:56 EDT
It's way too late to completely update a video driver to a whole new driver
version, as that would not allow time for proper beta test coverage to occur.
If a single small specific fix is known and someone can either attach the
fix as a unified diff patch to this bug report, then I can examine it
for potential inclusion.  Otherwise, I will need to know when it was
fixed in CVS, such as the CVS checkin date of the bug fix.  If I have
that information, I can examine the CVS commit logs, and perhaps extract
the specific bug fix.

Updating the entire driver to a experimental CVS driver to fix one bug
however has a very high risk of breaking more things than it fixes.

I will scan through the cvs-commits mailing list and see if anything
pops up.  If not, I'll need someone else to provide me with a patch, or
with the information I mention above that can help me to try and find
the patch.
Comment 23 Mark Pinto 2003-08-28 12:46:41 EDT
http://www.winischhofer.net/linuxsisvga.shtml#download
that's all i could find.  that thomas' site, who's the maintainer for the sis 
driver.  you can download the updated driver from there, if you dont wanna go 
through xfree86 cvs.  not sure if there's a patch available
Comment 24 Mike A. Harris 2003-08-28 13:48:32 EDT
I'm familiar with Thomas' website, however as I mentioned above, I'm not
willing to replace the entire existing sis driver with a completely new one
with large number of changes in between the two versions of which there
is high risk that there might be regression, and no way to properly test
it.

In order to fix this bug report, I need a very very very small patch which
does not do anything else other than fix this one single issue.  No
driver enhancments, new support, and other stuff, just this one bug fix.

I've got no way personally of knowing what the fix for this bug is, unless
someone can supply me with a very small patch that fixes this one issue,
or points me to where I can obtain it, etc.

This illustrates one of the massive problems inherent in XFree86.org
development process.  It is often quite difficult to fix a few bugs
without introducing a large amount of new sourcecode that is experimental
and has not had widespread distribution beta testing.
Comment 25 Mike A. Harris 2004-10-01 02:14:33 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.