This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1027510 - SELinux is preventing /usr/bin/wine-preloader from 'mmap_zero' accesses on the memprotect .
SELinux is preventing /usr/bin/wine-preloader from 'mmap_zero' accesses on th...
Status: CLOSED DUPLICATE of bug 665665
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7774f653e3da691a306c93c01e6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 20:21 EST by Christopher Meng
Modified: 2013-11-07 06:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 06:40:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Meng 2013-11-06 20:21:44 EST
Description of problem:
Run wine command under root in console(just installed it and try to start it up) with normal user in logined Desktop.
SELinux is preventing /usr/bin/wine-preloader from 'mmap_zero' accesses on the memprotect .

*****  Plugin mmap_zero (53.1 confidence) suggests   *************************

If you do not think /usr/bin/wine-preloader should need to mmap low memory in the kernel.
Then you may be under attack by a hacker, this is a very dangerous access.
Do
contact your security administrator and report this issue.

*****  Plugin catchall_boolean (42.6 confidence) suggests   ******************

If you want to control the ability to mmap a low area of the address space, as configured by /proc/sys/kernel/mmap_min_addr.
Then you must tell SELinux about this by enabling the 'mmap_low_allowed' boolean.
You can read 'unconfined_selinux' man page for more details.
Do
setsebool -P mmap_low_allowed 1

*****  Plugin catchall (5.76 confidence) suggests   **************************

If you believe that wine-preloader should be allowed mmap_zero access on the  memprotect by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wine-preloader /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ memprotect ]
Source                        wine-preloader
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           wine-core-1.7.5-1.fc21.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-96.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.12.0-0.rc7.git4.2.fc21.i686+PAE
                              #1 SMP Sat Nov 2 03:41:12 UTC 2013 i686 i686
Alert Count                   6
First Seen                    2013-11-07 09:19:07 CST
Last Seen                     2013-11-07 09:19:29 CST
Local ID                      c5598c01-2b48-4759-b0f3-433be8ae0c2b

Raw Audit Messages
type=AVC msg=audit(1383787169.594:595): avc:  denied  { mmap_zero } for  pid=6058 comm="wine-preloader" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=memprotect


type=SYSCALL msg=audit(1383787169.594:595): arch=i386 syscall=mmap success=no exit=EACCES a0=bf9818ec a1=10000 a2=bf9818ec a3=5a items=0 ppid=1 pid=6058 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=wine-preloader exe=/usr/bin/wine-preloader subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: wine-preloader,unconfined_t,unconfined_t,memprotect,mmap_zero

Additional info:
reporter:       libreport-2.1.9
hashmarkername: setroubleshoot
kernel:         3.12.0-0.rc7.git4.2.fc21.i686+PAE
type:           libreport

Potential duplicate: bug 665665
Comment 1 Miroslav Grepl 2013-11-07 06:40:08 EST

*** This bug has been marked as a duplicate of bug 665665 ***

Note You need to log in before you can comment on or make changes to this bug.