Bug 1027534 - Ghostscript gives unrecoverable errors on some PDF files
Ghostscript gives unrecoverable errors on some PDF files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ghostscript (Show other bugs)
6.6
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
QE Internationalization Bugs
: i18n, Patch
Depends On:
Blocks: 1159820
  Show dependency treegraph
 
Reported: 2013-11-06 22:24 EST by James Robertson
Modified: 2015-07-22 02:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: ghostscript-8.70-21.el6
Doc Type: Bug Fix
Doc Text:
Cause: Some PDF files containing embedded objects were erroneously treated as portable collections. Consequence: A "/syntaxerror" error when processing these files. Fix: Only PDF files with /Collection attributes are treated as portable collections. Result: Such files are processed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 02:50:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a catalog for a local electronics chain. (2.33 MB, application/pdf)
2013-11-06 22:24 EST, James Robertson
no flags Details
ghostscript-pdf-collection.patch (1.26 KB, patch)
2013-12-04 10:53 EST, Tim Waugh
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Ghostscript 690709 None None None Never

  None (edit)
Description James Robertson 2013-11-06 22:24:52 EST
Created attachment 820853 [details]
This is a catalog for a local electronics chain.

Description of problem:
Trying to convert some PDF files causes Ghostscript to give Unrecoverable error, exit code 1


Version-Release number of selected component (if applicable):
GPL Ghostscript 8.70 (2009-07-31)


How reproducible:



Steps to Reproduce:
1. # pdf2ps SCNOV2013_AU.pdf
2.
3.

Actual results:

Error: /syntaxerror in pdfopen
Operand stack:
   (/tmp/gs_PrtviN)   (<<\n  /ASCII85EncodePages false\n  /AllowTransparency false\n  /AutoPositionEPSFiles true\n  /AutoRotatePages /None\n  /Binding /Left\n  /CalGrayProfile \(Gray Gamma 2.2\)\n  /CalRGBProfile \(sRGB IEC61966-2.1\)...)
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1862   1   3   %oparray_pop   1861   1   3   %oparray_pop   1845   1   3   %oparray_pop   --nostringval--   --nostringval--   %array_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1149/1684(ro)(G)--   --dict:1/20(G)--   --dict:75/200(L)--   --dict:75/200(L)--   --dict:106/127(ro)(G)--   --dict:285/300(ro)(G)--   --dict:7/15(L)--
Current allocation mode is local
GPL Ghostscript 8.70: Unrecoverable error, exit code 1


Expected results:

A working Postscript file.

Additional info:

This issue does not occur with ghostscript 9.10
Comment 2 RHEL Product and Program Management 2013-11-09 23:34:59 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Tim Waugh 2013-12-04 10:53:16 EST
Created attachment 832728 [details]
ghostscript-pdf-collection.patch

This patch seems to fix it (found using git bisect).

From upstream revision 10008.

commit 6e93f4ded61a1d21f60dd42273a7de0a908d1076
Author: Alex Cherepanov <alex.cherepanov@artifex.com>
Date:   Wed Aug 19 16:22:08 2009 +0000

    Process embedded files as a portable collection only when /Collection
    attribute is defined in the document root. Bug 690709.
    
    DETAILS:
    Collection atribute is marked in the spec as optional because a PDF file
    need not to be a portable collection but every collection has /Collection
    attribute.
    
    DIFFERENCES:
    None.
Comment 9 errata-xmlrpc 2015-07-22 02:50:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1343.html

Note You need to log in before you can comment on or make changes to this bug.