Bug 1027561 - Cleanup unused event_idx compat property from rhel6.0.0 and rhel6.1.0 machine types
Cleanup unused event_idx compat property from rhel6.0.0 and rhel6.1.0 machine...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
x86_64 Linux
high Severity high
: rc
: 6.5
Assigned To: Luiz Capitulino
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 00:22 EST by FuXiangChun
Modified: 2014-10-14 02:54 EDT (History)
12 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.420.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1029539 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:54:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 FuXiangChun 2013-11-11 21:13:02 EST
Re-tested this issue with qemu-kvm-0.12.1.2-2.417.el6.bmig1.x86_64.

Result:
Migration is successful with machine type rhel6.0.0,rhel6.1.0,rhel6.2.0,rhel6.3.0,rhel6.4.0 and rhel6.5.0.  so private build fixed this issue.
Comment 9 Miroslav Rezanina 2014-01-27 02:51:17 EST
Fix included in qemu-kvm-0.12.1.2-2.420.el6
Comment 11 Xiaoqing Wei 2014-07-07 03:12:45 EDT
all machine types:
    RHEL7 as dest host raised failure after done loading the incoming migration

QEMU 1.5.3 monitor - type 'help' for more information
(qemu) KVM internal error. Suberror: 1
emulation failure
EAX=00000100 EBX=00012e68 ECX=0001d360 EDX=00011a85
ESI=00070744 EDI=00034300 EBP=00034348 ESP=00000000
EIP=00010000 EFL=00000046 [---Z-P-] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =9af2 0009af20 0000ffff 00009300
CS =f000 000f0000 0000ffff 00009b00
SS =9af2 0009af20 0000ffff 00009300
DS =9af2 0009af20 0000ffff 00009300
FS =9af2 0009af20 0000ffff 00009300
GS =9af2 0009af20 0000ffff 00009300
LDT=0000 00000000 0000ffff 00008200
TR =0000 00000000 0000ffff 00008b00
GDT=     0009af60 00000037
IDT=     00000000 0000ffff
CR0=00000010 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000000
Code=00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 <00> 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
q


/usr/libexec/qemu-kvm -monitor stdio \
    -name 'virt-tests-vm1' \
    -M rhel6.2.0  \
    -nodefaults  \
    -vga qxl  \
    -global qxl-vga.vram_size=33554432 \
    -device AC97,bus=pci.0,addr=03  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20140707-144555-8sYNRG0a,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140707-144555-8sYNRG0a,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20140707-144555-8sYNRG0a,path=/tmp/seabios-20140707-144555-8sYNRG0a,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20140707-144555-8sYNRG0a,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file="/home/freebsd10.qcow2" \
    -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pci.0,addr=05 \
    -device virtio-net-pci,mac=9a:81:82:83:84:85,id=id90zMJZ,netdev=idHUDrUi,bus=pci.0,addr=06  \
    -netdev tap,id=idHUDrUi,vhost=on \
    -m 4096  \
    -smp 1,maxcpus=1,cores=1,threads=1,sockets=2  \
    -cpu 'Opteron_G3' \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,password=123456,addr=0,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4  \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -no-kvm-pit-reinjection \
    -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x9 \
    -enable-kvm -incoming tcp:0:5200


src rhel6:
qemu-kvm-rhev-0.12.1.2-2.429.el6.x86_64
kernel-2.6.32-488.el6.x86_64

dst rhel7:
qemu-kvm-1.5.3-60.el7.x86_64
kernel-3.10.0-123.el7.x86_64
Comment 12 Xiaoqing Wei 2014-07-07 03:55:59 EDT
(In reply to Xiaoqing Wei from comment #11)

> src rhel6:
> qemu-kvm-rhev-0.12.1.2-2.429.el6.x86_64
> kernel-2.6.32-488.el6.x86_64
> 
> dst rhel7:
> qemu-kvm-1.5.3-60.el7.x86_64
> kernel-3.10.0-123.el7.x86_64

Oops, rhel7 pkg is not up to date,
using the 

qemu-kvm-1.5.3-65.el7.x86_64

 as the dst side,
keep src pkg unchange(already latest), on same hw, same libvirt guest cfg,
works fine(6.0.0 - 6.5.0 all tested.)
So should pass the QE test, set to verify

# virsh dumpxml cpu 
<domain type='kvm'>
  <name>cpu</name>
  <uuid>ab7939ad-9056-8931-7bf2-fd7883745bed</uuid>
  <memory unit='KiB'>4194304</memory>
  <currentMemory unit='KiB'>4194304</currentMemory>
  <vcpu placement='static'>6</vcpu>
  <os>
    <type arch='x86_64' machine='rhel6.1.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <cpu mode='custom' match='exact'>
    <model fallback='allow'>Opteron_G4</model>
    <vendor>AMD</vendor>
    <feature policy='require' name='perfctr_core'/>
    <feature policy='require' name='skinit'/>
    <feature policy='require' name='ibs'/>
    <feature policy='require' name='mmxext'/>
    <feature policy='require' name='osxsave'/>
    <feature policy='require' name='vme'/>
    <feature policy='require' name='topoext'/>
    <feature policy='require' name='fxsr_opt'/>
    <feature policy='require' name='cr8legacy'/>
    <feature policy='require' name='ht'/>
    <feature policy='require' name='wdt'/>
    <feature policy='require' name='extapic'/>
    <feature policy='require' name='osvw'/>
    <feature policy='require' name='nodeid_msr'/>
    <feature policy='require' name='perfctr_nb'/>
    <feature policy='require' name='cmp_legacy'/>
    <feature policy='require' name='lwp'/>
    <feature policy='require' name='monitor'/>
  </cpu>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source file='/home/test.img'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </disk>
    <controller type='usb' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
    </controller>
    <interface type='bridge'>
      <mac address='52:54:00:8f:a3:df'/>
      <source bridge='switch'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
    <serial type='pty'>
      <target port='0'/>
    </serial>
    <console type='pty'>
      <target type='serial' port='0'/>
    </console>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes'/>
    <sound model='ich6'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </sound>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </memballoon>
  </devices>
</domain>
Comment 13 errata-xmlrpc 2014-10-14 02:54:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.